Introducing conditions and branching in rules

FYI a user on Slack just posted this cool discovery:

I just figured out if you create a project with rules using the new editor and then convert that to a project template, the rules with branching are maintained in the template project. It’s a nice workaround until the new rule builder gets added to templates.

4 Likes

I’m with @Phil_Seeman, and I would like to have more than 5 branches. We need flexibility to make this feature work for everyone. How does this impact the 50 rule limit (by workflow) in Asana today?

:star2: Introducing the new rule builder in Templates, Bundles, and Workflows! :star2:

Hello Asana rules enthusiasts! :wave:

:link: Here is where you can now find the new conditions and branching for rules.

  1. :memo:… in project templates:

Open your template and click on “Edit”. Click on the “Customize” menu to the right of your screen, scroll dow to “Rules” and click on “Add new rule”.
ezgif.com-video-to-gif (10) (1)

  1. :package: … in Bundles:

Open your Bundle, Edit it, Add a Rule

ezgif.com-optimize (6) (1)

3. :arrows_counterclockwise: … in the workflow view :

[This update works differently than the two first ones]

Open the workflow. On top of a section, Click on “Add trigger”.
The “normal” rules builder applies, but you can now click on “Add more triggers”.

ezgif.com-video-to-gif (9) (1)

:moneybag: Pricing tier:
New rule builder in templates and workflows: Starter, Advanced, Enterprise, Enterprise**
New rule builder in bundles: Enterprise
*limitations apply

:game_die: Launch type: Gradual roll out: 10% → 50% → 100% - Complete as of Dec 1st

:star2: Early Access Available


Stay tuned for more updates and don’t hesitate to share your feedback.
The Asana Product Team is eager to hear from you! :rocket:

4 Likes

One cautionary note I’d add in terms of rules in Workflow - something that I’ve seen lead to confusion multiple times now with users, and which it could be argued is a bit of an Asana design flaw.

When you’re focused on a section/column in Workflow and you select to build a rule under “When task are moved to this section, what should happen?”, it starts you out with the trigger for the task being moved to that section, which makes sense. If you stay with that trigger, it’s all good and the rule, after being saved, will display in that section/column in Workflow.

However, Asana allows you to delete that trigger and change to any other trigger. If you do that, then when you save the rule, it will not display in that section in Workflow. This makes logical sense, because you’ve “broken the connection” between the rule and the section; that is, the rule’s trigger is no longer related to that particular section. The rule is then located in the main list of rules for the project under Customize > Rules.

The issue is I’ve seen multiple users think something is wrong or broken because “I created a rule in that section and it’s not showing!” Just be aware if you start a rule from a section in Workflow but then change to a non-section-related trigger, it will no longer show for that section in Workflow.

5 Likes

Well just tell people not to use Workflow :rofl: I found this view a bit hard to understand and use anyway…

Haha yes that’s one way to solve it! Can you contact the 150,000 or so Asana customers and let them know? Thanks!

1 Like

Joke aside, I never ever talk about this view unless someone asks :slight_smile:

1 Like

Hey guys,

My team and I are relatively new to Asana and have the Starter version.

For some reason, I was able to switch from the Classic Rule Builder to the New Rule Builder last week; but now the option to switch back (per instruction in [this post]) is no longer available to me. The rest of my team does not have the option to switch to the New Rule Builder. It is a pain trying to onboard the team when our rule builders look different with no way to change.

Is there something I’m missing? Please direct me to another article if this has been addressed.

Thank you!

It is possible that Asana is making it slowly impossible to roll back to be able to deprovision the old editor. We are currently in the middle of the deployment. @Phil_Seeman you were in contact with the PMs, maybe you can help.

I haven’t heard anything about that; @Marie maybe you could check on that?

Are they creating rules in the Workflow view? That view does not support the new rule builder yet. Better to use the Customize view to build rules from.

I’m checking, but I assume this is expected at this stage!

2 Likes

Thanks for the reply Phil. They are creating rules for the sections in their “My Task” views. I had one of my team members share their screen with me during the process, so I can confirm that the button to switch to the New Rule Builder is not visible to them.

Just to reiterate, I had the option to switch from Classic to New Rule Builder ~2 weeks ago and did so, and now do not have the option to switch back. Screenshot shows the available options when I click the three dots. The screen is creating a new rule in a newly created section (“asdf”) in My Tasks.

I use the desktop version, but looked at this on both Chrome and Brave with the same result.

Then that’s weird; they should be able to have the new Rule Builder. You might want to contact Asana support to see why they don’t.

You can only switch back if you have a blank rule-builder screen. Once you start building a rule, the option to switch back isn’t available. Open the new rule builder and go to the 3-dots menu before you start adding any component of the rule, and you should be able to switch back.

1 Like

Thanks Phil, I do have a parallel conversation going directly with Asana support. I’ll report back here if they give an answer worth sharing.

Also, I am unable to clear all of the components from the rule-builder screen. The last screenshot I sent is what Asana creates by default when I open the rule builder to build a new rule. The screenshot below shows what is left after I delete everything that is able to be deleted. This could just be another issue with my account specifically.

Actually that is what a rule looks like with all components cleared (that is, no values set for any of them).

I suspect it must be something specific to the Starter edition, as in my Business subscription I can still revert back. You can check that with support also, or see what Marie is able to find out here.

Hi @Michael_York and @Phil_Seeman

Our team confirmed that we only offer the ability switch back to the old builder for new rule. The option is not available when editing existing rule.

@Michael_York, can you confirm if you’re trying to edit a rule, or create a new one?

My screenshots were creating a new rule. The only difference that I see when editing an existing rule is the option to delete the rule. But still no option to switch rule builders. Phil may be correct; this could just be a bug in the Starter version. I have opened a ticket with Asana support as well and will report back when they have an answer or solution.

1 Like

Have you guys removed the branch limit!?
AWESOME!

1 Like

@Alexander_Ritter , not quite, but the limit has been raised considerably! :star_struck:
More details will follow soon within the public announcement…

2 Likes

Hello rule builders :wave:

I’m excited to share that we’re pushing back the limits of our new rule builder, allowing you to create even more powerful rules in your projects!

Currently => Soon
Max number of branches per rule 5 => 25
Max number of actions per branch 5 => 20
Max number of components (ie; trigger, condition, actions) per rule 50 => 100

Let me know in the comments if you have any questions :slightly_smiling_face:

13 Likes