Rules not working

I’m hoping someone can give me some advice.

We have created several multi-step rules to automate an intake form. Some using the old rule builder and others using the new version since it was launched. The form not only populates the main project but also auto-populates into their own specific team’s intake project, auto-assigns a team member, depending on the service or LOBs, and updates the status to ‘new’ (see attached for a simple version).

We have several of these, 37 in all, some a little more complex than others. We noticed this morning that some rules created using the new rule builder is NOT working. All were created and tested last week and functioned just fine.

I read that rules per project is limited to 50. I’m assuming we have not hit our limit, unless each option within a rule counts against the 50?

Is there something I’m missing? Help. Asana support has not been responding to my ‘help’ tickets. So any suggestions would be greatly appreciated. Thank you!

1 Like

Not sure what you mean by “option” but each action in a rule counts as one against the limit. So in your screenshot, if that rule fired it would count as 3 against the limit.

Thanks, Phil. Yes, actions. Thank you for the terminology correction. I used the wrong vernacular. Each platform has their own language. So, just so my team is clear, each action counts against the 50 rule limit?

Is there a way around this? For example, if I create a rule with a one action that shares the new intake request task into another project, can I create an assignment and a status change rule in the shared project? Maybe???

Right, each action in a rule counts as 1 against the limit whenever that rule runs. So as one example, say a rule has 5 actions in it and it runs 3 times, that counts as 15 against the limit.

Okay. That adds up. Do you think the idea I posted above could work? One action rule in intake project A will get activated to share the intake task into another project B. And in project B, another rule to assign and change the status. Could that work to split the number of actions?

By the way, I appreciate you walking me through this. The forum is a blessing when things like this happen and everyone is freaking! LOL!

@Maria_Susan_Angustia and @Phil_Seeman,

I believe you’re both talking about different things.

Maria’s mention of “50 rules per project” is about item 2.1 in this post. Your screenshot represents one rule; you’re allowed 49 more of those in a project so that’s not likely at play here if you only have 37. But note the other limitations in that post in section 2 which apply to rules; perhaps another limit is being exceeded?

Phil is talking about the fact that certain plans only permit executions of limited number of rule actions per month (like 150 or 1500 actions per month).



You could well be right, @lpb. I’m confused, though, because

sounds to me like rules that were working and not aren’t would be a function of the run limit.

But yes, then there’s

So @Maria_Susan_Angustia I’m not sure what limits we’re really addressing here, sorry.

1 Like

No apologies needed @Phil_Seeman. Thanks for trying to help solve this dilemma.

@lpb I added new multi-step rules last week. Tested them and they worked. When we received an intake task with actions that should have triggered the rule, it didn’t work this week. The new intake task should have been shared into another project, assigned a team member and status was not changed.

Like mentioned, we have 37 rules in the intake project. Some rules are as simple as one action, others have up to three. They are all “Active”. I think I’m well below the limits - rules, run and action limits (we have a Business account). No way have we reached 25,000 actions this month.

I’m not sure of my next steps. Should I delete the ones that aren’t working and start all over?


Yes, I think you should try to delete and recreate the simplest rule that’s not working and test it; if that fixes it, do the rest.

But still, if it worked last week, and not this week, and you’re sure nothing changed, then that would still be unexplained, and no reason it might not stop working again.

I think you still need to pursue this with Support who can investigate more deeply. You mentioned you haven’t gotten a response but also mentioned “tickets.” If you reply to a thread before they answer, you’ll be sent to the bottom of the queue, so best to wait for a reply.

By the way, Phil won’t be able to reply today.



1 Like

Thank so much @lpb! And great tip about the ticket reply process. I was just about to follow-up! :wink:

1 Like

@lpb and @Phil_Seeman

Some of our rules continue to have issues. I did as suggested above, I deleted one and rebuilt it using the old rule builder. It did not work. I also received a response from Asana Support about adding one more “Check if” scenario to the rule. But the suggestion also did not work.

Quick question for you experts… Our intake form that triggers these rules have questions with branches. Do all single-select questions in the form that answers a “Check if” scenario need to be connected to a “field” in the project to allow the rules to get triggered? Hope that made sense.

Any additional advice you can pass on would be greatly appreciated by our team. Thank you in advance.

If I understand your question, then yes!

It may help to think of rules as not really being related to the form at all. The form creates tasks. The rules operate on tasks. (The check-if trigger that task is added to the project by a form is the only real exception.)

So the check-if rules that operate on custom fields, single-select or otherwise, are operating on tasks’ custom fields; they have no memory of the form. If the form doesn’t connect the question to a custom field, then the rule won’t trigger.

Could that be the issue?

@lpb I just tested it, and YES, that was the issue! :dancer:

My next question is in regard to the connection. My team wanted to add additional rules that requires earlier questions to be connected to custom fields. If I make a mistake, it appears you CANNOT reverse a connection. Asana Support told me they can’t reverse it on their end and to be careful. If I connect an existing question (that was not connected already), the branches below it turns red. Which was alarming. Can I reconnect those? Or do I need to rebuild the branching questions of the form?

1 Like

I’m glad that fixed the problem.

I’m not sure what you mean by “reverse” and given the complexity of your rules and time involved, I’m not comfortable using this format to advise you, so I’d better stop here…thanks.

1 Like

No worries. Your help in guiding me to understand the concepts around rules was the bigger lift. I think I can manage from here. I tested my theory out on a less complicated form and it worked. You are awesome! Thank you! :pray:

1 Like

Great to hear; thanks, @Maria_Susan_Angustia!

Not sure what you mean by “option” but each action in a rule counts as one against the limit. So in your screenshot, if that rule fired it would count as 3 against the limit.