Can't Create New Rules for Subtasks - "Create rule" is disabled

Hi guys!

I’m working on setting up a photoshoot list for my company, and need to have various folks auto added as a collaborator so they get updates on where their stock is in the production pipeline.

Until yesterday, I’d been creating rules to do this with no problem, but all of a sudden it’s not letting me save any new rules?

I tried using a coworkers account (to make sure it wasn’t something with mine specifically) and evidently NO ONE can add new rules to my board.

Any idea what’s causing this? Screenshot of the rule-creation window below, with the “create rule” button unclickable

Hi @Oliver_Harkness and welcome to the forum,

There is a limit of 20 rules maximum per project; are you perhaps at that limit?

1 Like

Thanks for the suggestion, and the welcome @Phil_Seeman!

Just counted and I only have 9 rules currently. They do all have two triggers, is that the issue?

@Oliver_Harkness, did all your rules stopped working or is the problems just with new rules?

All of my old rules are functioning, and I can edit them. I just can’t make new rules

@Oliver_Harkness Did you recently downgrade your Asana account from Premium / Business to the Basic version? The Rule feature is not available to users on the Basic (Free) level.

Here is a breakdown of the level of functionality for the Rules features between the different class levels:
(Basic, Premium, Business, Enterprise)

Anything shows up when you put your mouse over the disabled button?

Not that I’m aware of - I think a rule with multiple triggers still counts as just one rule. @Community_Managers can you confirm that?

Nope, my Asana account is Premium through my work and we’re functioning almost fully through the platform.

No, sadly. No cursor activation at all and nothing happens when I click.

If you stay still for 3 seconds, there is no explanation showing up as a tooltip?

Just gave it a shot, no luck.

I am out of ideas. @Emily_Roman @Rebecca_McGrath any idea?

1 Like

Hi all, thanks for flagging this and sharing your ideas! I investigated this further and I would like to clarify and confirm a couple of things:

  • There is a limit of 20 Rules per project.
  • When you hit the 20 Rules per project limit, the + Add Rule button in the Customize menu is disabled so you wouldn’t be able to get to this page to add a new rule.
  • You can currently add 5 actions to a single rule, which is not the case here as you only have one action which is “Assign task”.
  • Even if the Rule has multiple triggers, it will count as one Rule in your project.
  • The Create rule button is usually disabled if not all fields are filled out.

I just have a couple of extra questions before I escalate this to our product team:

  • Since we couldn’t reproduce this on our end, could you confirm if you have followed this troubleshooting steps in your browser? We are aware that Ad blockers can cause similar issues.
  • Have you tried creating a Rule using a different trigger and action, does the issue persists?
  • Have you already tried creating new Rules in other projects? Could you send us the URL of one example project?
  • Could you send us a screenshot showing the current list of Rules in the Customize menu?
  • I see you are mentioning “Rules for Subtasks” in your title, could you clarify how you used to create Rules for subtasks? Rules currently only work for subtasks after you manually add them to the project.

Thanks in advance for the extra information! Moving this thread to our #bugs:report-a-bug category so we can continue investigating :slight_smile:

2 Likes