Update Field Does Not Trigger Rule When Field Is Updated By Rule

Briefly describe (1-2 sentences) the Bug you’re experiencing:
I have a task multi-homed in 3 projects. Each having rules in each project to process the task when marked completed, moved to completed, and when Task Status field (from library) is set to completed. Rules trigger on all three, then action all three so no matter the user input, we capture completion.

However, there is a defect. When I update the field, the task completes, and moves in all three projects. Great, as expected. When I mark the task complete, the task updates field, and moves in all three projects. Great, as expected.

BUT, when I move the task in one project, it completes the task, updates the field, but does not move it in the other two homed projects.

So, the schema works in 2 of the 3 scenarios.

To be super clear. The defect is that when I automate a chance to the complete or field update, the rule in the other projects do not see that change. It should not matter how the field changes, or how the task is marked complete. The rule states Task marked complete and Task Status changed. There is no asterisks stating only when changed manually.

Not sure why this would have been coded that way in the first place. Why the listener can’t hear when an update is automated in this one scenario. That is, the Mark Complete and Field change are both automated rather. The listener should be agnostic to what make the change.

Steps to reproduce:

  1. Create 3 projects (or two just for demo)
  2. Create 3 rules per project
    Triggers:
    Task Moved to a certain section <> Completed
    Task marked completed
    Task Status changed <> Completed
    Actions: (do the inverse)
    Task Moved to a certain section <> Completed
    Task marked completed
    Task Status changed <> Completed
  3. Create 3 Tasks multi-homed in all three projects with tasks names Marked Complete, Task Moved, Status Changed
  4. For each task, complete by means of task name.

You will see that two of the tasks (Completed and Status Changed) completed all the actions. But the Task Moved, never moved on the projects it was multi-homed with.

Browser version:
Version 91.0.4472.101 (Official Build) (x86_64)

Upload screenshots below:
I do not see anyplace to upload a screenshot??

Sections are project-specific (not global). Moving a task to a section in one project will not cause the task to move sections in any multi-homed projects. In this example, you are only satisfying the trigger in the project you are working within.

1 Like

I am not asking for a section change to trigger a section change

The move triggers a rule that updates the field and completes the task.

The rules in the other two projects do not pick up the field change or the completed task change.

I know.

Only in the project where the move is made.

Right. Because no trigger was met. A rule can’t trigger a rule.

1 Like

Haha, okay. Seems like you want to have the same conversation because you are posting the same question again. Answer hasn’t changed, but I understand you don’t want to accept that. Good luck with this. Honestly was just trying to help.

For the record, the moderator marked it as solved. Just saying.

1 Like

@Marie please open this back up as it is not resolved. Thank you.

Hi @Getz_Pro, and thanks for reaching out!

While I understand your frustration regarding the issues you touch based in your post, please try to keep your feedback constructive and respectful of other Forum members; as a reminder, you can find our Community Forum Guidelines here . We are only trying to help you.

I had a look at the description in your first post and I agree with the solution provided by Jerod. Moving a task to a section in one project will not cause the task to move sections in any multi-homed projects.

Since you mentioned this is not the main issue here, in order to investigate further, we will need URLs of some project impacted. I can only run very limited research on my end in the forum, so I’d recommend reaching out directly to our support team and send them the project URLs. They will be better suited to help here and give you a detailed answer: How to contact our Support Team ✉

1 Like

Hi @Getz_Pro!

Bingo - those two sentences capture the scenario perfectly! What you describe there explains what @Jerod_Hillard was trying to point out and why the “another rule” won’t fire - the fact is Asana rules do not fire based on task changes made by other rules.

I don’t like that behavior, either (and in fact my Flowsana rules don’t behave like that; they fire as the result of other rules), but it’s not a bug - it’s the way the Asana folks decided to program the functionality of rules. Rather than a bug report this belongs as a Product Feedback item so that people can vote on changing the behavior (and frankly there’s probably already one out there for this request!).

Personally I agree! But significantly, Asana does not and that’s what counts here.

I haven’t talked with them about it directly but I believe the reason for this behavior is that they’re worried about a circular loop, and that’s a valid concern. Because Flowsana doesn’t have this limitation, I’m taking a risk that someone might create a series of rules that leads to an endless loop cycle of updating. It hasn’t happened yet, but then, I have a few less users than Asana does. :wink:

That is why I am posting a defect. It should, but it does not. That IS what a defect is.

I am not here to get quorum that it works the way it works. I see that. My issue is, it should not, and therefore that is a defect.

Can I please have a developer come in and review defects?

A defect occurs when an intended use is not met.

@Emily_Roman please state what was offensive? To be constructive is not what others are doing. I am, by reporting a defect. Others are jumping in with, but that’s how it works. Which is obvious and the reason why I am submitting the defect.

@Getz_Pro,

I’ll leave the other aspects of the discussion to the moderators… :slight_smile:

To clarify the part I’m discussing… This particular part of the forum is for reporting bugs. The definition of a bug, in software terms, is a piece of software code whose behavior deviates from the intended behavior of that code. In this case, what you’re pointing to is not a bug, as Asana’s rules evaluation is exhibiting the exact behavior that its coders intended it to have. That’s why the moderators closed this report.

Now you can absolutely call it a design flaw - I would! That’s something to be discussed in the Product Feedback section, which is the perfect place for making the case that a piece of Asana program behavior, while it might behave the way it was intended to, should have a different behavior. Hence my suggestion to write up a Product Feedback post so others can also vote for a change in the app’s behavior. Except, as I suspected, there already is one, and it already has 102 votes (including mine - I just voted for it)!

(Also, the moderators can clarify this but I’m almost positive Asana’s developers don’t directly deal with bug reports here in the forum - when a bug is reported here, it goes to the support team, and if they can verify it as a bug, they file a report for it in some internal software system at Asana.)

1 Like

Thanks @Phil_Seeman

Having worked with software devs for many years, I understand that what everyone else would call a defect is referred to as planned functionality.

A software bug is an error, flaw or fault in a computer program or system that causes it to produce an incorrect or unexpected result, or to behave in unintended ways.

Thanks for the other link. I think I’ll just stick with not reporting issues or feedback as they tend to always start drama.

This topic was automatically closed after 6 days. New replies are no longer allowed.

Hi everyone!

I’m opening this thread to let you know we are rolling out Rule Chaining. With this update, you will be able to trigger a Rule from an action made by another Rule both within a project and across projects.

You can find more details in the announcement: New! Automation Rule Chaining ⚡

@Getz_Pro in regards to your initial report, with this update this workflow should work know. You just need to enable “Allow this rule to be triggered by other rules” option in the Rule settings.

Hope this helps! and let me know if you have any questions.

1 Like

Thank you @Emily_Roman I am glad this fix is finally in place.

Appreciate you adding the comment here!

1 Like

This topic was automatically closed after 7 days. New replies are no longer allowed.