Unable to join team

Hi

I am new to Asana and am looking to join my department’s team, but it does not show up. They added me and I get email notifications of new posts, tasks, etc., but I am unable to join the team on the website. When I type in the team’s name, it does not show up. When I type in a known teammate’s name, Asana shows that he or she is not part of any team. Is there something I am missing?

I have more or less copy pasted the text from this community post post which describes exactly the same problem - Trouble Joining a Team - the solution mentions something about a bug in chrome but I have tried in chrome and edge and I get the same results.

It’s very frustrating as I’m receiving email notifications and tasks are being assigned to me but I’m unable to access them. Is anyone able to help?

Thanks
Tom

Hi @Tom_Williams,

From what I can see, you’re a member of several Workspace/Organisations so you might not be looking at the right space, here is how you can switch between space: https://asana.com/guide/help/fundamentals/about-asana#gl-switch Let me know if that help!

Hi Marie,

Thanks for getting back to me and for the advice. The problem I have is that I’m unable login to Asana to switch workspaces. When I enter my email and password to login I can only get to the page below which forces me to choose a team but since I cannot see the team I need to join I’m unable to fully login. Seems like a bit of a catch 22.

Any ideas?

Thanks
Tom

The only way I was able to solve this was to create a new project of my own and then invite myself to it. Then switch to the existing project I had been invited to, then delete the test project that I created to log in.

Glad you worked it out @Tom_Williams and sorry to the trouble, I’ve filed a task for our team to take a look into this behaviour!