OneDrive SharePoint File Picker does not load SharePoint sites any more

Briefly describe (1-2 sentences) the Bug you’re experiencing: I am no longer able to pick from my associated SharePoint libraries when attaching files to tasks via the OneDrive / Sharepoint file picker. This was working great until 2 days ago.

Steps to reproduce:

Browser version: Chrome Version 92.0.4515.159

Upload screenshots below:

2 Likes

Hi @Brian_Harry, welcome to the Asana Community Forum :wave:t2:

Let’s try to solve this together. Could you please try the troubleshooting steps below and let me know if any of these help resolve the issue?

Looking forward to hearing back from you :slight_smile:

Hi! I’m having the same issue. I’ve tried the troubleshooting steps and nothing works.

Hi @Brian_Harry and @RafaelV, thanks for your report! this is currently a known issue and our product team is investigating. We hope to have a solution soon! We will let you know as soon as we have any updates.

Hello,
When I’m trying to attach a file from SharePoint, i choose the Onedrive/SharePoint-button. However, the SharePoint files aren’t shown. It is only showing OneDrive files.
Of course, I could attach them from “Your Computer”, this is however not the ideal situation since the edits from collaborators are not synced in SharePoint.

The link with SharePoint worked properly before. Please let me know if you have any idea on how to fix this.

Hi @Nick_Hoffmans, thanks for taking the time to provide this feedback.

While it’s not possible to browse using the SharePoint integration at this time, hopefully this is a feature our Product team can look to implement in the future.

I’ll keep you posted on any updates :slight_smile:

Hi Rebecca, Thanks for replying. This used to be workig properly. What happened?

Hi @Nick_Hoffmans, thanks for your report! We investigated this further and you are right, there is currently a bug and some customers are unable to attach files from Sharepoint. I’ve gone ahead and escalated your report to our product team so we can investigate further and solve this issue asap. We’ll keep you posted!

1 Like

We are another account with the same issue, maybe our logs will help the product team. We can no longer access SharePoint via the usual attach file menu. Worked a few days ago, now all users only see OneDrive as described above. There do not seem to be any recent changes to SharePoint or Azure in Microsoft’s changelogs or admin notifications.

Our organization is also affected by this. Hoping for a resolution soon!

We also are having this issue. Following to know when a resolution is reached.

We are also having this issue.

For about a year, we’ve been able to use the task’s Attachment icon > OneDrive/SharePoint to link to a file on a SharePoint site. Now, the OneDrive window opens but SharePoint sites are no longer listed on the left like they used to be. Our SharePoint Admin is unaware of any change on our end.

Do you all still see SharePoint sites listed there, or is this happening for everyone? Any idea why these went away? We don’t want to use the sync to OneDrive feature for various reasons… so as a workaround, people have to paste a shareable link in the task description or comments.

Our Office 365 Admin told me he has two apps enabled in Azure AD for immediate authentication for our users – “Asana For Teams” and “Asana OneDrive thumbnails”. Is there another one that is now needed for this integration to work?

I’m including a screenshot of an image I found online showing SharePoint sites lifted on the left pane under the OneDrive My Files section. We used to see that list of SharePoint files, and we no longer do.

image

Hi @Heather_Beaudoin, thanks for your report!

There is currently a bug and some customers are unable to attach files from Sharepoint. This has been escalated to the product team so we can investigate further and solve this issue asap. We’ll keep you posted!

2 Likes

Checking back in on this as it is impacting our internal workflows and client access to files. Can someone from Asana please provide an status update on this as it’s causing issues here. Thx

Thanks for letting me know it’s a bug. Do you know when this issue started/was first reported? What’s Asana’s policy on updating us on fixed bugs? Will I be notified when it’s fixed since I identified as someone who is impacted by it? Since it’s not working, I won’t be clicking the button until it’s fixed, so I won’t just see it’s fixed all of a sudden.

1 Like

We are also having this problem and its happening just as Im setting up a large number of tasks with linked files!! Is there any update on this bug?

I thought it was just me

1 Like

I opened a ticket with support on this issue last Tuesday (9/7/2021).

After the initial - have tried with other browsers, clearing cache, etc. I haven’t received a response?

Is there an update on this issue? This a major work blockage for our users.

Emily - What is progress on this solution? It would be great to hear when/why this feature stopped working, and when it will be remedied.