OneDrive picker never loads

Have never been able to get OneDrive attachments to work. Initially sure it was because Asana didn’t support OneDrive for Business (which we used to use).

Either way, we’re now using standard OneDrive via Office 365 and when I click ‘attach via OneDrive’ I get the popup window, am asked to login to OneDrive but I’m then just left hanging with a progress dial spinning endlessly.

FYI I’ve also tried in incognito mode to check it’s not an extension conflict, but get the exact same.

Any ideas?

Thanks.

Hi @Blinkertoon :wave:t3: and so sorry for the trouble!

I suspect this issue might be due to the fact that your browser currently doesn’t allow 3rd party cookies.

Here’s how to enable them in Google Chrome:

  1. At the top right, click the three stacked dots and then Settings.
  2. At the bottom, click Show advanced settings.
  3. In the “Privacy” section, click Content settings.
  4. Use the “Cookies” section to change your settings:
  5. To allow first-party and third-party cookies, choose Allow local data to be set.
  6. To block all cookies, choose Block sites from setting any data. When you use this setting, most sites that require you to sign in won’t work.
  7. To allow only first-party cookies and block all third-party cookies, check the box next to “Block third-party cookies and site data.” This setting means that site data cannot be written and read, even if you’ve added a site to the exceptions list and have chosen to allow its cookies.

This is also covered here: https://support.google.com/chrome/answer/95647?co=GENIE.Platform%3DDesktop&hl=en

Can you give this a go and let me know if you’re still running into the same issue?

Looking forward to your reply!

Thanks for the quick response Marie… although your instructions don’t seem to obviously relate to what I can see. Have attached screenshot. Could you try to direct me again?

Thanks.

Thanks for trying these steps. Other users have reported the similar issue, and from our initial investigations, it seems that the issue might be related to users set up in their Microsoft environment (See this thread in which users are reporting the same issue when trying to attach a doc from OneDrive to Trello). We’re in touch with Microsoft to fix this issue and I’ll make sure to keep you posted as soon as I have more updates.

In the meantime, you should be able to work around this issue by syncing your OneDrive with your computer and upload attachments directly from your computer. I’m aware this is not ideal, but hopefully it will help fir the time being!

Thanks Marie. Good to know of any fixes – and already aware of attaching actual files, but as you say not really ideal. Strange how Google drive works OK though?

Thanks.

Neil

1 Like

Yes, looks like the issue is specific to OneDrive! I’ll make sure to keep you posted as soon as I have an update o this topic!

1 Like

Hi Marie,
Are there any updates on this? We’re encountering this issue as well.

Thank you,
Austin

Hi @AdR,

Not yet I’m afraid… Have you gave a go to this workaround just to unblock you fo rthe time being?

I did try that. My options were already set to allow third-party cookies. :frowning:

Thanks for letting me know.

I was referring to this part in particular :point_up_2:

Hi,
is there a fix available now for the onedrive problem ?
Wordaround is not a really fix because everybody has to upload every file again after changes…

Hi @Oliver_Kruse, welcome to the Community Forum :wave:

We don’t have any updates at the moment. The workaround would be the solution in the being, we completely understand it is not ideal and we will make sure to post any updates we have.

Hi Oliver,

I agree, this is not ideal. We have been putting the Sharepoint link in the task description. It’s better that attaching the document, but it’s still not ideal.

Katie

Hi folks,

Just a quick word to let you know that our Dev Team recently shipped a brand new OneDrive file picker, so this issue should now be resolved! If you’re still running into trouble please let me know!

Marie,

Great news! Should this roll out for everyone at the same time? I still get issues after I’m asked to login to my onedrive account.

Thanks,
Katie

Hi @Katie_Reynolds,

Just to double check, are you having the issue on Chrome?? If so have you made sure to allow 3rd party cookies?

1 Like

Thanks Marie,

Yes, I am using Chrome with Asana. I checked my setting and it looks like I am allowing cookies (see below). I’ve cleared my cache and logged out of Asana and back in. When I’m asked to log into my OneDrive account I still don’t get pat the login box. Is there another cookie setting or step to reset that I’m missing?

Thanks,
Katie

I am getting the same result on Firefox. With Edge I am getting an error box in Asana to turn off the pop up blocker, but even when I turn it off I still get the message.

Katie

Thanks for the quick follow-up and additional information @Katie_Reynolds, really appreciate it.

From what you’re saying, it looks like this bug might not be resolved just yet. I’ve gone ahead and re-opened this bug with Development Team, and I’ve shared with them all info above. I’ll be in touch as soon as I have an update from them.

Again, my sincere apologies for the inconvenience, and thank you so much for taking to the time to follow-up on this issue. I’m closely following this bug in Asana, and I’ll be in touch asap!

1 Like

@Katie_Reynolds,

Re:

I think there is, actually; it’s called “Block third-party cookies” and it’s on this settings page: chrome://settings/content/cookies which is different than the setting you showed.

The instructions in @Marie linked to in order to find the setting are no longer correct I think, which maybe led to your not finding it. I’m not sure this is the cause of your problem, but worth a try, at least on Chrome.

Larry

1 Like