Project tasks: Attaching documents from Google Drive

Hello! I’m trying to attach a document from Google Drive, but I keep encountering an error that reads:

The feature you requested is currently unavailable. Please try again later.

Has anyone else had this error; Is this an issue with asana or with my computer?

Did you try to try again later :stuck_out_tongue: ?

Hopefully it was resolved, but in case it wasn’t - I do know there’s issues with attaching from Google Team Drives. Perhaps that’s what’s causing it if you’re using a Team Drive.

1 Like

Thanks for the replies. I’m not using a team drive, it’s just shared with two members on my team. I’m just wondering if it’s my computer, in which case I really don’t know how to fix it, or if it’s asana.:face_with_raised_eyebrow:

Hi @Abigail. We want to help! Could you please provide a screenshot? That will help us determine what the problem is. Thank you!

Thanks so much for your help :slight_smile:

1 Like

Hey guys – Google Drive was DOWN yesterday. I know because we were on a 4 am call (yes, you heard that right) with Europe and Google Drive was failing.


Was there a solution to this problem? I am having the same issue today.

If I log onto Asana/GSuite account from a Chrome Incognito tab, I can attach.

I have tried restarting Chrome and cleared some of the browser history, but have tried resisting deleting all of my browser history/settings

Update: I am having issue with Chrome even after I clear browsing data/Cache etc…
Also tried from Laptop and Desktop

1 Like

Hey @Peter_Cioe, the problem from the initial post was that google drive itself was down during that time period.

If it’s working in incognito but not in your main browser, I would suggest perhaps it’s an add-on/extension issue as those do not carry forward in incognito.

Well I am having the same issue and have been for a week now. While other google accounts can add documents from Google Drive to our projects I still can’t. So I doubt it is related to Google drive being down.

How do I get support for this? This is the only thread that explains the issue I am having. Seemed best place to start the conversation, because my screen shot would look the same, it has the same error message.


Thanks for checking in! We’re very sorry to hear about this issue. Our product team is aware of the issue and we hope to see a solution soon.


I have the same problem. Did you found solution?

@Volodymyr_Berezovsky are you seeing a Google drive attachment problem? Could you please provide a description and screenshot(s) of what you’re seeing? Thanks!

Good afternoon

I send you video for better understanding.​

Thank you for the context! Yes, this appears to be the same issue as before. Looks like we’re still waiting on a solution. I’m very sorry for the delay! I hope to see a fix soon.

Thank you for your answer. I will ask you send me email when the issue is

Hi @Volodymyr_Berezovsky, @Peter_Cioe, @Abigail -

It looks like we found a solution!

Do you have Chrome configured to block third party cookies? You can find this setting in Settings → Advanced (a dropdown) → Content Settings → Cookies → “Block third-party cookies”. Make sure this is disabled. If you enable it, google drive does indeed stop working.

It seems to be a known issue and someone posted a solution on YouTube :slight_smile: :

​Thank you Alexis.
Now its working and its awesome.
Thank you a lot

That’s great to hear @Volodymyr_Berezovsky!