Unable to connect to Google drive

Hi Guys,
As Admin I setup G Suite then added Asana from the Marketplace.
Been login in using “Use Google Account” and everything works fine until I need to attach a file from Google drive, using the attach button in Tasks. This is the error we get: “Attach Google Files - Sorry, we were unable to connect to Google. Please try again later.”
Is there something I’m missing/doing wrong? any fix?


Hi @Jeantife_L! Are you trying to attach a file from a Google Team Drive by any chance? I’m asking this because Asana currently does not have an integration set up with Google Team drive which may explain why you are running into this error! Keep me posted! :slight_smile:

1 Like

Hi Marie,
Thanks for your email.

I am trying to attach files from My Drive as we don’t have Team Drive.

Please see screen recording.


I’m having the same issue. Recently created a G Suite account and can’t upload files from Google Drive with the error:

Sorry, we were unable to connect to Google. Please try again later.

I am also logged in to Google with a private account. Can there be an issue with two active accounts even though I select the G Suite account when trying to upload?

To add to the mystery, another user of the same G Suite domain is able to upload files.

Looking forward to a solution.


Hi, I’m having this same problem. New Asana user. We have an Organization level Asana account and I’m trying to connect our Google Apps using the same domain name and email address. It’s normal Google Drive, it’s not a Team Drive. “Sorry, we were unable to connect to Google. Please try again later.”

Please help, thanks!

Experiencing the same issue. I’m not sure this is a team drive.

Hi @Ketil, can you please try this steps if you haven’t already? Asana supported browsers and troubleshooting steps | Product guide • Asana Product Guide

Are you able to reproduce the issue with another browser or using an incognito window?

Same issue here. I am using Google Drive via a G Suite Basic account.

I have used Asana with G Suite with multiple domains but this is the first time such important & basic functionality isn’t working. ASANA we need a solution.

Been using asana for a while and something like this never happened, it has been like this for almost a month already.

The only way i can do it is by using incognito mode. which is a pain to do everytime i need to attach something.

To open incognito do Ctrl+shift+n.

I am having the same problem. Tried clearing my history/cookies/cache in Chrome, and also tried doing it in Safari (which I never use, so I have no extensions or anything installed). Still not working. Please fix this!

1 Like

Same Issue for me. Either I get the prompt right away, or sometimes I see the form to enter my google account credentials. But then, after I entered my credentials I get the prompt anyways. Tested on Chrome and Firefox, normal and incognito mode. Always same behavior.
Side note: I use a VPN, which however shouldn’t make a difference as all traffic is routed transparently. No issues when directly accessing google services whatsoever.

Hi, this has been bothering me for a long time already. Last week I fixed similar issue with gmail signature. The culprit was Ghostery or Adblock Plus chrome extension. I tried put Asana into trusted sites and now attaching from G Drive works fine.


I was able to fix this issue while using Chrome by opening the Cookies Settings Page (chrome://settings/content/cookies) and adding the following URL to the Allowed list at the bottom of the page:


I’ve seen the recommendation elsewhere in the forums here to disable blocking of all third party cookies (which is an option higher up on that setting page) but I believe it’s more secure to “deny all unless expressly permitted”, than “permit all”. In this case use of G Suite justifies the override.


The forum software turned the domain name In the last post into a link. Just to be clear, make sure to use that whole line for the domain (including the “[*.]”, which will match all subdomains).


This worked for me when all the other suggestions here didn’t.

I am battling to connect to Google Drive via the app. It is possible to connect when working from the website version of Asana, but when I use the app it says “Sorry, we were unable to connect with Google”.

I have seen and attempted to apply all the cookies-related steps that others have proposed, and have also added Asana and Google as ‘allowed’ sites in my Cookies settings, but still no go. Is it possibly a glitch in the App?


Hi @Heather_Moore and welcome to the Forum!
So sorry to hear you’re running into trouble here; let’s see if we can work that out together. Are you referring to the iOS or Android app?

Hi Marie
Thanks for getting back to me, and apologies for the long delay. I’m in Cape Town, South Africa, so we’re in different time zones!

I’m working on a PC, Windows 10, where I’ve downloaded the Asana App from the Microsoft store.



Thanks for following up @Heather_Moore! Unfortunately this app is a third party app, we did not develop it, so we’re not in the best place to troubleshoot or fix it. I would recommend reaching out directly to the developer (you can find he contact details at the bottom of this page: Microsoft Apps).

Apologies for not being able to help further there!