Unable to connect to Google drive


#21

Hi Marie

Aha! This makes a lot of sense. Thanks for pointing this out.

I think how I’ll proceed, then, is to use the Chrome integration for quick access, cross-integrate with Slack, and use the browser version of Asana for all other engagements.

Thanks again for your help,

Heather


#22

You’re very welcome Heather :slight_smile:


#23

AWESOME! Thanks Scott, that worked perfectly :slight_smile:


#24

First day Noob of Asana here… what I’ve read so not only do csv files don’t import correctly or have a details field, now I’m reading that Google Drive Integration is a problem for Asana??? This is not effortless project management at all!


#25

Hi @Anna_Downs,

Could you please let us know what issue you’re running into with Google Drive? Would be more than happy to help!


#26

As Scott said, its a cookie blocking issue. You have to allow Google’s cookies for it to work. Here are the guides to do it in Chrome and in Firefox:

https://support.google.com/chrome/answer/95647
https://support.mozilla.org/en-US/kb/websites-say-cookies-are-blocked-unblock-them


#27

I followed all steps to allow Google’s cookies.
But I are unable to connect to GoogleDrive anyway.
“Attach Google Files - Sorry, we were unable to connect to Google. Please try again later.”


#28

That does seem strange @Swen, can you try to log in from an incognito window? Are you running into the same issue?


#29

Thank you, @Marie!
I logged in from an incognito window and it works.
Strange…
I will now check what the reason could be.
But as long as I have a workaround now every is fine. Thanks!


#30

Great news @Swen! If it works with a private window, the issue is probably related to an extension installed in on your browser, so if you have recently installed a new one, I’d recommend disabling it and see if it resolves your issue!


#31

i was able to resolve the problem by following @Scott_Burns’ suggestion above. i am using Chromium 69.0.3497.100, so my settings might be slightly different than his build from August 2018, but i had to go to “Advanced Settings” -> Privacy and security -> Content settings -> Cookies . in the “Allow” section, i added:

[*.]google.com


#32

Sometimes it happens due to the caches or cookies so clear all cookies and caches also take help from Google drive server error if further face any difficulty related to the Google drive.


#33

Had the same issue here, followed the suggestion from @Scott_Burns worked like a dream! Thanks for that Scott!!


#34

Hey @Marie, I’m seeing the same error but it persists in an incognito window and another browser. Any ideas?


#35

Hi @Jon_Yergatian and sorry for the trouble there!

You might be getting this error because of your browser currently not allowing 3rd party cookies.

Could you please try these steps in Chrome?

  1. At the top right, click the three stacked dots and then Settings.
  2. At the bottom, click Show advanced settings.
  3. In the “Privacy” section, click Content settings.
  4. Use the “Cookies” section to change your settings:
  5. To allow first-party and third-party cookies, choose Allow local data to be set.
  6. To block all cookies, choose Block sites from setting any data. When you use this setting, most sites that require you to sign in won’t work.
  7. To allow only first-party cookies and block all third-party cookies, check the box next to “Block third-party cookies and site data.” This setting means that site data cannot be written and read, even if you’ve added a site to the exceptions list and have chosen to allow its cookies.

This is also covered here: https://support.google.com/chrome/answer/95647?co=GENIE.Platform%3DDesktop&hl=en

Let me know how this works!


#36

Same issue, ghostery somehow was blocking it. Only way to resolve was to pause ghostery, even whitelisting asana didn’t work for me.


#37

Hey @Marie, I’ve attached a screenshot of my Chrome settings. Based on the documentation you provided, I would expect the Google Drive function to work but it does not.