Export to .CSV - UTF8 Issue

export

#1

We have tasks in Georgian language. Exporting to .CSV seems to be a problem:

Exporting to JSON seems fine:


UTF problem for .csv export - Excel VBA solution
Please add XML export
#2

Hello! Is the error you’re referring to the #### in several cells? This happens when the column is too narrow for the data to appear. I recommend expanding the width of the column - that may solve your issue.


#3

Hi Alexis, no not ###. I am talking about afafafafaf strange characters.

I am uploading screenshot as an example. Please have a look at task title field. In green you will see English words in title which look well but Georgian words are shown as “afafafafaf”…

"


#4

@kshengelia I understand. Unfortunately this is a bug - we apologize for the inconvenience. The bug has been reported and our team is aware. We’ll have a solution for you as soon as possible.


#5

I have an update for you, @kshengelia. We have a workaround! It is possible to export non-English characters from Asana, however some versions of Microsoft Excel open the exported .CSV file with different encoding, which causes some characters to appear incorrectly. If you open the file in a different spreadsheet program (e.g. Numbers on macOS) these characters should appear normally. If you open it using a text editor (e.g. Notepad, or TextMate), these characters should appear normally as well - but the export is not easy to read in this format.

To open the file in Excel and have it display correctly, you can change the encoding of the file. There are a couple of ways to do this.

  1. Open the file in Excel, select the File menu and then click Save As.
  2. In the Save As window, there is a Tools button at the bottom
  3. Click it and go to Web Options
  4. On the Encoding tab, you can select ANSI from the ‘Save this document as’ drop-down menu
    Save the file and try and open the new version again. It should now appear normally

If you use Google Drive, you can also upload the export file to Google Drive and then download it again. This should download the file with ANSI encoding instead, and Excel should display the characters normally.


#6

Thank you @Alexis for suggestion and being helpful. It’s strange I cannot find ANSI in given options:

Anyway, I am not really using this feature yet, just wanted to let you know about this issue.


#7

I have found a workaround. Maybe I am only one who worries about this but still, someone might find it valuable :slight_smile:

Workaround is pretty straightforwad:

  1. Export to JSON
  2. Copy JSON value
  3. Use JSON to CSV converter like this

#8

Unfortunately, there is no export to JSON option for advanced search. So, this workaround does not really work for this.


#9

Unfortunately non of your solutions worked for me!


#10

Sorry to hear that! How can we help?


#11

Is not working either for Spanish. This bug is almost a year old. When will it be fixed?
Other applications/sites are doing fine with encoding without the need of Excel tweaks.


#13

@Alexis Neither of the proposed solutions worked also for me, except for opening it with LibreOffice, however saving the file(s) back to .csv or .xlsx made the file(s), lose the characters. And even if that have worked, it’s not the way to work with and process even >10 files :frowning:

Are there any news when this bug will be sorted out? Quite some time it is there


#14

Here is a solution for the cases when there are not many files: If you import .csv from “Data/GetExternalData/From Text” by setting delimiter to “,” everything is imported perfectly.
Capture


#15

Thank you!
I tried this with Hebrew.
It works, only that the comma delimiter creates problems with columns containing commas - if I created the task from e-mail, for example.


#16

I also had a similar problem and thought it was because of comma, but it appeared to be the case with invisible RETURN (Ctrl+J) character. So needed to write a vba script for initial cleanup of the files.


#17

I tried exporting to JSON and converting to CSV online as well. It worked. In case, this is the JSON to CSV converter I used.


#18

Still waiting for this. I’m a paying user, I have also reported this in private several times and always get the “we love & care for your feedback” and then nothing, no resolution.


#19

Please, we need to be able to export in a more decent format. This is what external users see when I share exports from Asana with them: IDs in scientific notation and special characters messed up


#20

CSV-export messes up German Umlauts and, obviously, chokes on commas contained in project text. Could you please add XML-export?


#21

Welcome to the Community Forum @Jurgen_Scriba and thanks for your feedback. We already have a very similar topic in the #productfeedback category, so I have gone ahead merged your post with it (Export to .CSV - UTF8 Issue) Unfortunately votes aren’t carried over when threads are merged, so I’d recommend adding your vote to this main thread!

I would also advise you to check out this post: UTF problem for .csv export - Excel VBA solution that contains some handy workarounds!