CSV Importer Now Available


Hi There

I am trying to use the CSV importer but are having difficulties.

I created a simple test project in ASANA. It has a board or two, some tasks and some subtasks with dates and asignees. I then used the CSV exporter to create a CSV file, I used this to get a litte more insight into the format.

I then created a new test project and tried importing the exact same csv I exported before. For some reason it does not allow me to map any fields, I get this message “Something doesn’t look right? Try changing Encoding Settings”. I tried all the listed coding but nothing works.

One would exspect that if you export a project, you should be able to import that project again to create and eact diuplicate?

Can you please asisst?



The importer needs to support the creation of projects, tasks and sub-tasks to make it easy to move over from other todo list platforms. I’ve tried to move myself from Wunderlist but it’s way too painful. I have multiple Projects in Wunderlist, I can’t spend time creating them manually and then importing each set of tasks, it’s just too painful. The omission of sub-tasks is also important, almost every project has a task->sub-task relationship, this needs to be supported please.


@Maimoona_Block can you help or provide some insight to my posts? :smiley:


Hi @Jerod_Hillard apologies for the delay and thanks for your feedback. Will you confirm I’ve captured it correctly? You’d like to see the CSV have these features:

1.ability to import subtasks
2.ability to import tags
3.ability to import descriptions-this is possible (everything is put in the description field by default) so can you provide more information on what you are looking for.

I’d love to hear about your use case, so if you are interested in chatting by phone, please DM me.



@Maimoona_Block, your quote below is correct. I discovered this after further testing. Initially, I didn’t think this was something available because the field wasn’t specified in the blog post I read.

A stretch wish list would be for Dependencies (if the task or subtask exists and is appropriately referenced within the file being imported) and Attachments

I would love to connect to further discuss our use case and the potential here. I’ll DM you. Thanks!


I second @Colby_Stream on the Descriptions. We need to be able to import directly to the Descriptions field, just like we can with Name etc… Sure, having the ability to combine everything on a row into the Description is an interesting bonus, but I already have valid descriptions of tasks that I need to import. Let’s be honest, the Description field is pretty important. It is built-in, prominent, and the best place to add, well the task’s description. I almost could not believe it when I could not select this field for importing.

After unchecking the box to import the whole row into Description (which would be horribly redundant and require a lot of manual editing to clean it up) I should be able to add another field, DESCRIPTION and point it to my column with the same name (or any column in my CSV, actually). I just tried it and 1. I cannot add the Description field to my import. 2. I cannot even select my Description column from the CSV for anything else! This almost seems like a bug.


Hi @Randy_Hanson thank you for this feedback! I am adding another vote for the description field mapping to our CSV importer update tasks, but can you clarify #2. Are you trying to map a column named “Description” to a custom field?


Yes I am, but the importer should not be limited to that in any case. I should be able to pick whatever column I have in the CSV. In my test, I have a Description column with a sentence of text in it. I cannot select it for mapping to anything, and I cannot pick the Asana Description as the destination for anything either.


In other words, I cannot import any CSV column to Description–not even from column I have that is named Description.

In fact, the only way to import anything into Description is to check that box and import the whole row. That is not a helpful solution, but it is an interesting bonus.


Ok thank you for clarifying. I’d love to hear more about your overall use case if you would be open to chatting. If so let me know via DM.


Thanks. The community system here won’t let me send you a DM. Here is my use case:

I have a spreadsheet full of tasks. I have columns for Task Name, Description and Due Date.
I save a .CSV and attempt to import into a project in Asana.

The importer lets me import NAME, and a properly formatted Due Date, but I cannot import my descriptions.

That’s it. This is extremely straightforward, and illustrates what I view as a major shortcoming for an otherwise very convenient import feature. My CSV task list leverages Description as you would expect: I have detailed descriptions of each task, or additional information about the task beyond just the name.

To make it more interesting, let’s build on this use case and add additional columns to the import. Say I have something like 20 other custom fields with numbers, text and drop-down choices. I need to import all 23 columns. Everything will work EXCEPT the very important Description. It is also impractical to check the box that allows the whole row to go into Description, as this would duplicate the other 22 fields and waste valuable visible space when viewing the tasks.


Is there a way to import Due Time ?


Hi @Randy_Hanson thank you for the feedback. I’m adding this to our feature update tracking task.


Just starting with Asana for my company and can’t get the cvs import function to work. I get only a blank dialogue box. Is the app working at this time?


Hi @1710coopboard! Sounds like this could be a browser issue, have you already tried these steps: https://asana.com/guide/help/faq/connectivity#gl-troubleshooting


Thanks, I am well connected, This isn’t working in the latedt versions of Chrome or Firefox with adblocking disabled. I get a pop-up dialogue box titled ‘Add Tasks via CSV’ that does nothing else. Any other ideas? Thanks.


This blank dialog box is what I get with all browsers (adblocking disabled). No ‘file browse’ or drag and drop possible.


+1 Subtask import is very important


When we go to use the CSV importer, we get an error message. I wanted to share in case other are experiencing the same error.


Hi @Lauren_McMahon,

Thanks for letting us know about this. Sorry to hear this is happening for you! Before I send this on to our engineers, would you mind helping me rule out any possible browser issues by trying the following steps? This will give our team the right information in order to investigate.

  • Test Asana on another supported browser. If it works in Firefox but not in Chrome, for example, this indicates that the problem may be with Chrome, and one of the steps below may help fix it: https://asana.com/guide/help/faq/connectivity#gl-browsers

  • Disable browser extensions while using Asana. You can test this by using an incognito or private browsing window. This disables browser extensions by default. If it works in Incognito/private mode, you may need to try switching off some of your extensions to see if any are causing conflicts with Asana: https://asana.com/guide/help/faq/connectivity#gl-troubleshooting

  • Update your browser to the latest version.

  • Clear your browser’s cache.

If you’ve already tried some of these, please still try the others. If your issue is not resolved, please don’t hesitate to let me know. Thanks!