Can't delete an empty section (with no tasks)


I can’t delete a section even if it’s empty (with no tasks), I’ve already checked similar topics, but none worked for me.

Her’s my project configuration :

  1. No tasks in this section
  2. No rules
  3. Sort is set to None
  4. No filters
  5. Private project

This is the project link


This is strange. I can’t think of scenarios where you will not be able to delete a section. @pforumleader would any of you know of something we are missing?


Is this in My Tasks? If so, you can’t delete the one section that used to be called Recently Assigned–Asana relies on its existence.

Otherwise, I’m not sure the cause.



No, as mentioned before, it’s a Private Project and this bug happens a lot of times (also in Public Projects), so as I can’t fix this issue I have to delete completely the project and start from scratch.

I think it’s a bug and if there’s no solution I hope Asana will fix it in the upcoming update.

Best regards.

1 Like

@Community_Managers, Should this be changed into a Bug? Or should @_Hamza go through Support?



I know :slight_smile:

That happens in Board view, you can’t delete the last column. If you happen you rename this last column, then it appears in List view and you can’t delete it either :slight_smile:

Capture d’écran 2021-12-10 à 11.53.56

This makes sense, You need at least one section in a project. @_Hamza Is this the case on in your scenario?

@Paul_Grobler I’m afraid not :slight_smile:

When you create a new projet there’s no section.

@_Hamza When you create a new project it looks like there is no section but click on the board view and you will see a section called “Untitled section”. See screenshot below.


@Paul_Grobler that’s not my issue, the section is in List view, when you create a new project there’s no section in List view. As I mentioned before, the problem occurs sometimes, not in all projects. So I believe this is a bug. I was able to delete all section in other projects.

Go to the Board, find the task and delete it. I had the same issue.

I had the same problem but successfully solved after creating another new section.
Seems that asana does not support an empty project without titled sections anymore.

@Kranny @lpb @Cynthia_Bournellis I’ve already mentioned that there’s no task, the section is empty. Check my first post I explained the issue, and my other answers to know more about the issue :slight_smile:

@_Hamza our experiments show that we can reproduce the issue, but indeed can’t delete the section afterwards :man_shrugging:

Hi everyone, apologies for the delay here!

As @Bastien_Siebman mentioned, it’s currently not possible to delete the last column in a project. When you create a blank project, it will automatically include an “Untitled Section” in Board view. If you rename this section, it will automatically appear in List view and unfortunately it can’t be removed. This section will be always visible in Board view on all newly created projects but if you don’t want it to appear in List view, you can’t rename it. At the moment, Board view needs to be linked to at least one section/column.

We are aware of this and we hope to improve this behavior in future updates, in the meantime, you can upvote here Remove untitled section in Board view. We will also post any updates in the thread in the #productfeedback category once we have any updates. Thanks for sharing your feedback!

@Emily_Roman Thanks for the clarification. I voted in the topic you mentioned. I hope they will be able to fix it, because it’s confusing for the customer, and I had several times deleted the project and start from scratch :frowning:

This topic was automatically closed after 4 days. New replies are no longer allowed.