Advanced Search > Due Date > Within the next . . . Includes due dates from past

Briefly describe (1-2 sentences) the Bug you’re experiencing:

Search parameters include Due date > Within the next > 3 months, but search results include tasks with due dates in the past.

I believe from past discussions that Asana considers an incomplete task with a due date in the past as due today.

I don’t want the search results to include due dates that have passed.

Steps to reproduce:
Search using “in Projects” field. Select one project.
Attachments = Any
Completion = Incomplete
Due date = within NEXT 3 months
Also used custom field Country = US

Browser version:
Chrome Version 91.0.4472.114 (Official Build) (64-bit)

Upload screenshots below:

Hi @Angie_Canon, thanks for flagging this! I’ve gone ahead and escalated this to our Engineering team! I’ll keep you posted and let you know when I have any updates :slight_smile:

1 Like

Hi @Angie_Canon, this has been confirmed as a bug by our Engineering team! They are working on a fix for this so I will let you know as soon as I have any updates here :slight_smile:

Thanks for your patience!

1 Like

@Rebecca_McGrath Please make sure Engineering team keeps this in mind: Custom reports with a "next X days" filter for due dates used to show overdue tasks as well (until last week). *Please* bring it back.

@Rebecca_McGrath - We went through this very conversation last December with @Marie and Asana rolled back the change at the request of myself and many others.

As I outlined in the post that @Angie_Canon linked to, this could be solved with a checkmark option to include or not include overdue tasks.

Please, please do not make us go through that mayhem again.

1 Like

I have a report to view incomplete, upcoming tasks. It is currently also showing my completed tasks from April.
This is a report view I have used for months. The bug appeared in the last couple of days.

Steps to reproduce:

Advanced search, select Incomplete, Due in next 1 week

Browser version:
Google Chrome Version 90.0.4430.85 (Official Build) (64-bit)

Upload screenshots below:

1 Like


This is the filter I set

Hi @Rhian_Davies

Firstly, welcome to the forum!
Sorry you are experiencing problems with this report. This def looks like a bug. I attempted the same filter, but the result came out correct - no complete tasks showing.

I suggest reporting it directly to asana support team so they can assist accordingly.
Here is the support form - you can select the option 'Let’s Talk & ‘something is not working’

Thanks,
Rashad

1 Like

Submitted. Thanks @Rashad_Issa

1 Like

Hi @Rhian_Davies, this has been confirmed as a bug by our Engineering team! They are working on a fix for this so I will let you know as soon as I have any updates here :slight_smile:

1 Like

FYI, looks like this is fixed for me now.

Hi, @Rebecca_McGrath - did you see my comment above?

I’ve very nervous about pushing this as “a bug” because it was a deliberate decision to listen to users and roll it back last December. Finding a new solution to toggle overdue on or off, that will solve the needs for both users. But, simply removing the overdue tasks from the report will paralyze the way millions of users have been using it for years already.

If you want to read about the many use cases that show why it’s crucial to include overdue tasks, please reference the December post linked in my comment earlier in this thread.

In summary: a task doesn’t suddenly become less important to see because it’s simply become overdue. In fact, at that point it’s MORE important to see.

I do hope they offer a toggle to show or not show overdue, but please do not just remove overdue tasks from our “due soon” type reports.

Thanks so much, @Rebecca_McGrath, for the time you take to moderate these discussions.

Thanks for following up, @Bry_ProjectKickstart. I hear you! I’ll relay this info back to our Product team. There are no updates yet but I will let you know as soon as I hear anything :slight_smile:

@Rebecca_McGrath I am having the same problem. Any word on a fix for this bug? It looks like it has been going on for 5 years: