Added Tags Not Showing Up

Hello,

This issue is driving me crazy. I have made task, and then I added a tag to it. I had to create it, as it was new. All done, good. Then I go to new task, and I try to add the previously created tag, but it does not appear in drop down suggestion, instead, It asked me to create new tag (again), and I create it - having two tags now with same name.

And I have been doing this over and over again, now I have same name tag 4-5 occurrences, as it does not show up in tags section in drop down.

For example, I create tag called mhh for task 1, and it gets made. Then I go to task 2, and in tags section, when i type mhh, my previously created tag does not show up. and it says again, create tag mhh, and i create again. … when I go to minimalist work - Work less with better tools and methods, I now have a series of same name tags, just because asana is not giving me option of choosing from previously created tag.

Hi @Abhishek_Kapuria,

Is this happening with more than one browser? Can you confirm what browser (+version) you’re using?

Hello Marie!

I have the exact same issue. I have multiple tags with the same name. this defeats the purpose of the tags in the first place. It would also be great if there is a way to see a list of all tags within the app. I use the Asana app on MacOS v12.1 (Intel).

Thanks for your input @Ioannis_Koupidis. Can you confirm what browser you’re using? (Safari? Chrome?) Could you also confirm the verios of your browser and if you can reproduce the issue with more than one browser?

Hello Marie!

As I wrote clearly in my previous message, I am using Asana via the native Mac app. Not through a browser.

Thanks @Ioannis_Koupidis, I’ll go ahead and file a bug for our team to investigate. If possible, could you share some screenshots illustrating the issue?

@Abhishek_Kapuria can you confirm if you’re experiencing the issue on the web or on the desktop app? Thanks!

@Ioannis_Koupidis could you confirm if this issue only happens after creating a new tags? or is this happening with all tags - new and existing ones?

Hello Maria!

It happens both with old and new tags.
What I have noticed is that it happens mostly with older tags that haven’t been used for a while.

A few other things I noticed:

  1. If I Try to add a tag that I know I have created before and it doesn’t show up, I get to create a new tag with the exact same name. This creates huge problems since I no longer can click on that tag and get an overview of all the tasks with that specific tag.

  2. When I do an advanced search on a tag I noticed that I no longer get results on it like before.

  3. From what I understand I can only see a list of my tags via API. I have no idea how to use an API. It would be great if I could see all the tags that I have created within Asana.

Thank you @Ioannis_Koupidis,

Let me check in with our engineers and get back to you!

1 Like

Hi all,

So let me tell you what the issue was, and how I have fixed it, for time being.

Say I create a task called Test, and give it NEW tag called “Quote” by creating a new tag. All good. Test task now carries “Quote” tag.

Now, say I remove this “Quote” tag from the Test task, and add another new tag called “Quote Reminder” by creating it. Good. It also gets made.

The problem now will come, when say I go to another task (old or newly created), and want to add the tag “Quote”. It does not show up in drop down suggestion, while I just made it! It says create quote tag once again, and I was making tags after tags with same name…

What I have figured out is this - Asana is not displaying names of tag, which have no task associated with them! So, in my case as I outlined above, I was seeing the suggestion for Quote Reminder tag, but not Quote tag (because I had removed it from tag section and replaced with Quote Reminder, and Test task still carries it).

So here is what I am doing now.

  1. I make dummy task for each tag I want to use, and I do not remove tags from them. So I have Test-1 task which has Quote tag, and then there will be Test-2 task which will have Quote Reminder tag.
  2. As long as the dummy task carry my tags, I can use them on any project task. They appear on drop down suggestion.

Clearly this is a Asana issue, where it is letting go of an tag memory if it is associated with a specific tag. So if you plan to create 8 tags, I suggest you make 8 dummy tasks with each tag and put them in a sleeper section (whatever you call it). And you are all set for future use of these tags.

Hope this helps with anyone else who has similar issues.

2 Likes

Amazing find Abhishek!

1 Like

Thanks for the find, that is so annoying

Hello. I am also having this issue. I am using Chrome v 100.0.4896.127.

When I create a new tag (and choose the color and all that), the new tag is not showing up in the drop-down of available tags, so I’m forced to create a new tag each time. Asana recognizes them as separate tags.

I am having this same issue. So far, the following is happening with a newly created tag.

  1. If I try to add the newly created tag to a new task, it doesn’t show up in the drop down menu. However, the “create a new tag” option appears.

  2. Sometimes the tag will show up in the Advanced Search option. But not always.

  3. The tag I am having issues with does have a special character in it (a $) so I was wondering if this could be the issue?

  4. Also, it appears (due to this glitch) 3 versions of the same tag may have been created by myself/my Team when they were prompted to “create a new tag” when setting up the task. And now Asana is recognizing them as separate tags.

  5. I am using the app on a PC and also via browser in Chrome.

The last entry to this problem was in May. I started using Asana in mid September and the issue is still there. I am trying to figure out to use Asana or Trello. With that kind of support and bugs Trello seems better option. I am surprised :frowning: because I use to use the Asana couple of years back and it worked well.

Hi I hope you are fine in both health and spirit. I am having the same issue ,I have created many tags but Asana is not showing many from them. Anyone?

Hi I hope you are fine in both health and spirit. I am having the same issue ,I have created many tags but Asana is not showing many from them. Anyone?

We also have the same issue. Tags can work fine for quite some time, then just suddenly stop appearing in the drop down - leading to issues with duplicated versions being created and tags not reporting accurately.

Unfortunately Abhishek’s solution does not work for us - these tags are associated with plenty of tasks but still stop appearing. However, some do include special characters (!) so perhaps Allison_Kiser is correct.

Either way - Asana Team, this has been a bug for some time now. Please could we have an update @Marie as it is limiting our ability to use the platform properly.

@Marie I am experiencing the same issue using Safari and Chrome on a desktop and the app. When I create a new tag, it disappears once it’s removed from a task.