When logging into desktop app, doesn't redirect back to app from browser to authenticate

Briefly describe (1-2 sentences) the Bug you’re experiencing:
When logging into the app it directs me to the web and even if I’m already logged into asana on the web it logs me out and makes me log back in. Once I log back in it doesn’t redirect me to the app to authenticate
Steps to reproduce:
Just try and log in. Can do it 20x in a row and doesn’t work correctly
Browser version:
Chrome Version 96.0.4664.110 (Official Build) (64-bit)

Have tried uninstalling and reinstalling, clearing browser cache, disabled all extensions, and even tried changing default browser with same results every time. Running Windows 11 latest build

2 Likes

This happens to me as well and is very disappointing, I cannot use the asana app because of it.

Hi @Dre_Sassenrath, @Shawn_D, welcome to the Asana Community Forum :wave:

Thanks for flagging this! In the Apps tab of your Profile Settings, do you have the open links in app toggled on or off?

Briefly describe (1-2 sentences) the Bug you’re experiencing: When. I try to sign into Asana on Mac OSX app, I’m directed to a sign-in experience in browser. When I complete this, the Asana homepage opens in my browser, and the app remains on the “Sign in” page.

Steps to reproduce: Click “sign in to asana” in desktop app. Log in via SSO on browser.

Browser version: Chrome 96.0.4664.110

Upload screenshots below:

Hi @Nik_Shah, welcome to the Asana Community Forum :wave:

Thanks for flagging this! In the Apps tab of your Profile Settings, do you have the open links in app toggled on or off?

I don’t have that option when I’m on the web version. I only have Asana Community and no Asana Desktop.

I’m using SSO when trying to sign on

Hi, I have this issue as well as does my entire company at the moment. The “open links in app” is toggled on and we have never had this issue before. I have tried reinstalling the app and logging in and out on the browser but nothing has worked.

1 Like

Hi @Laura_Schmitz and @Shawn_D ,

I have attached another user’s thread about this as well. I have provided links for this problem as well. Please follow the exact steps outlined in the directions as it may be more than one issue preventing you from the opening the app correctly. Thanks!

1 Like

I have already tried all these troubleshooting steps with no success

I have also tried doing it from an incognito windows as well with no luck

Hi Rebecca,

This is also happening to myself and others at my organization. When logging in to the the Asana app it directs us to the browser to login using SSO. However, we are not being redirected back to the app. All are using Mac’s, Safari or Chrome. We are able to using the web version, but are not redirected back to the app after log in. Tried uninstalling, clearing cached. restarting. Everything is updated.

1 Like

We have multiple people at our organization having this issue

Are there any other troubleshooting ideas or have you not updated the newer code for Windows 11

@Shawn_D, @Loren_Cavener, @Laura_Schmitz, this sounds like a developer/software issue that I am unable to assist with. Have you all opened tickets with Asana support? They are able to view bugs and software issues from their end. Please find the link below:

Hi Rebecca,

I left you a comment, I also do not have the Asana Desktop app as an option in my app setttings:

<img width=“365” height=“217” style=“width:3.802in;height:2.2604in” id=“Picture_x0020_6” src="//discourse-cloud-file-uploads.s3.dualstack.us-west-2.amazonaws.com/asana/original/3X/6/0/60299af1d77bc0781646d23ed72cbdc9efb44641.png" alt="Graphical user interface, application

Description automatically generated">

image002.png

I opened a ticket with support and suggest others with the same issue do the same

1 Like

Same problem here - It seems like a recent regression as I had been using Asana desktop sucessfully with SSO for months.

Having this issue too! No option to toggle on desktop app within settings. Glad I’m not crazy at least

HI all, thank you for flagging this!

I’ve gone ahead and escalated this to our Product team. I’ll keep you all in the loop and let you know when I have any updates. :slight_smile:

4 Likes