Asana never bring me back to the app after browser login

Briefly describe (1-2 sentences) the Bug you’re experiencing: The Asana app login redirects me to login via the web version of Asana – but I am never redirected back to the Asana app, and thus cannot log in to that app. It never recognizes that I am logged in.

Steps to reproduce: try logging in again
Also, tried uninstall and reinstall app again. didn’t work. same thing happened.

Browser version:

Upload screenshots below:


Hi @Daniel_Kwok,

Do you use PC or Mac? As a Mac user, I know there is a setting that you can switch on or off for you problem.

Go to the web version of Asana, click on the top right icon, select “My Settings.”

Then, navigate to the “Apps” page of your settings. At the very top you should see the following icon:

If this does not work, I would encourage getting in contact with Asana Support if you haven’t already. I have provided the link at your convenience.

1 Like

Hi Mike,

I use PC. I also check the setting and “Open links in app” is turned on.

Please let me know if you know of any other remedy. I really like the app version of Asana.

1 Like

Hi Mike

I am using PC and have the same issue as Daniel. Can’t use the App anymore…

1 Like

Hi @Simon_Bürgi and @Daniel_Kwok,

Sorry for the delayed response. I was able to find another user having the same issue in the Community Forum. I provided the thread link in here, as well as the Asana support link for browser/desktop app issues. Please follow the step by step process as there’s a possibility it is more than one issue to attend to.

I’m having the same problem as the others but this doesn’t seem be the solution (unless I’m missing something?) –– that person doesn’t want to use the app (but it keeps opening the app) but these people do want to use the app, but can’t.

1 Like

This same issue has been reported many times in these forums, but never resolved and simply closed due to inactivity. Is there any way to have this reported as an actual bug that needs to be fixed and just not forgotten about?

1 Like

Hi Mike,

Thanks for posting the thread link here. I’ve tried clearing any history on my browser including cache, cookies, etc. It is still having the same issue. Please help and escalate this.

Hi @Mike_Tammaro,

In case you are not getting notifications for this thread. Please see the responses below.

Hi @Daniel_Kwok ,

I am unable to escalate this at my level. But I am able to provide you with the Asana Support team. It looks like your issue is bug related and requires a support team to investigate further. Please find the link below.

For those of you on here who are as confused and frustrated about this. Here is the response from Asana Support:

"Hi Daniel,

Thank you so much for writing in and informing us of this issue, I apologise for the inconvenience!

This is actually an issue that has been brought to our attention on several occasions that we have already escalated to our Development team. They are currently investigating the bug in question and hope to have it resolved as soon as possible.

I went ahead and added your report to this escalation and assure you that I’ll be in touch as soon as I hear back from the Development team.

Feel free to let me know if you have any additional questions or queries and I will be more than happy to assist you with them!

All the best,
Emily "

1 Like

This topic was automatically closed after 6 days. New replies are no longer allowed.

HI folks :wave:

I just wanted to let you all know that this issue should now be resolved! :tada: If you’re still running into issues, please let me know :slight_smile: