Use 12-hour time format and DD/MM/YYYY

Is there a way to make Asana display 12-hour format time and DD/MM/YYYY format dates in Chrome at the same time?

If I set my Chrome language to English (US) I get 12-hour format and MM/DD/YYYY.

If I set my Chrome language to English (Australia) (I’m Australian) I get 24-hour format and DD/MM/YYYY.

On the Android app I don’t have this problem. By default it is 12-hour format and DD/MM/YYYY so it seems like it should be possible on the desktop too!

I’m using Chrome Version 75.0.3770.100 (Official Build) (64-bit) on Windows 10.

1 Like

Hi @Josh_Craig, you are correct, date/time format is based on the region the browser is in. Does the same happen in other desktop browser?

Hi @Vanessa_N. Thanks for the response. I’m only interested in using Chrome.

I understand why Asana would display date formats based on browser language but it makes no sense that it changes the time format too. In Australia, times are much more commonly expressed in AM/PM format then 24 hour format anyway.

Worse still, I’ve found that if I type ‘3pm’ into the 24-hour format field it returns ‘03:00’ not ‘15:00’.

Is there really no way to switch between 12-hour and 24-hour time format? Anyone?

Hi @Josh_Craig
I am an Oz Chrome user. I haven’t noticed this issue. Once I get back to my PC will check my settings and respond.

Jason.

1 Like

Apologies for the trouble, @Josh_Craig, unfortunately, it is not possible to adjust the date/time format directly in Asana at this time. It really depends on the browser settings. Even if you won’t use Chrome, testing a different browser will help us understand if this is an issue with Chrome or all browsers. If it works in other browsers but not in Chrome, it’s very likely that you are facing a browser-related issue.

Would you have any other device in which you can try to reproduce this issue with Chrome?

In the meantime, I will make sure your feedback gets to our Product team, and hopefully, we will be able to add this feature to Asana so that users can customize their date/time settings according to their region. Looking forward to your reply!

Hi @Vanessa_N, @Josh_Craig
Have just tried this on my MacBook Air. Same problem and with both Chrome and Firefox.

For what ever reason the Time Field in Asana only has 24hr clock when the Language Setting is set to Australia Region. Regardless if you are using 24 hour clock or not.

When you change it to US Language it is fine.

Hope this helps…

Jason.

Hi @Vanessa_N

I tried with Microsoft Edge on my laptop with the English (Australia) language setting but on there it maintains American date format and 12 hour time format.

On the other hand, in the Asana app on my Android phone I do get the 12-hour time format and DD/MM/YYYY by default.

Thanks for your help @Jason_Woods. It seems like such a simple thing!

Thank you for getting back to me, @Josh_Craig and @Jason_Woods. I’ve reached out to our Team for more information regarding this behaviour, and they have confirmed that the time format is dependent on the person’s operating system (language and region preferences) AND browser settings (language settings).

@Josh_Craig, in order to better assist you, we kindly ask you to reach out to our Support team directly as we will need information that we don’t recommend sharing publicly.

It would be great if you could go to the following link for our teams to investigate further:

http://www.localeplanet.com/support/browser.html

At this link, you can view what the browser is telling you (including time settings).

In your email to Support, please provide them with a screenshot of what you can see at the link, ensuring to include the entire browser window (including the clock at the top right corner please).

This will allow us to better understand if there is a potential bug here or where (if anywhere) things may be misconfigured. Also, please include a link to this forum thread in your email so that you don’t have to repeat everything to our Support.

Thanks for doing that! Hopefully, there will be an easy solution for this issue. :slight_smile:

1 Like

I’ve already emailed support and they provided me with a pretty cursory response:

‘As this is a Google Chrome language settings related issue, and not Asana product related, I am afraid we can not provide the response to this query.’

Hi @Josh_Craig, I’m sorry to hear that. I’ve located your query in the system and will follow up with you via email so that you can reply with the additional details for our team to investigate the issue. Your response will come directly to me and I will take care of the escalation. Thank you! :slight_smile:

1 Like