Task due date-picker/calendar hopping up and down depending on month

Briefly describe (1-2 sentences) the Bug you’re experiencing:

Depending on the number of weeks in a given month, the task due date date-picker widget displays above or below the date line. When clicking through months, the user e.g. ends up clicking outside the widget, e.g. on the “Asana Upgrade” button. Frustrating.

One screenshot is provided below. I run into the error “New users can only put up one image in a post”, so I let you figure out the other one rather than wasting more of my time pasting two images into a single PNG :slight_smile: .

Steps to reproduce:
See above.

Browser version:
Chrome 80.0.3987.122 Windows 10 desktop.

Upload screenshots below:

Welcome to the Forum @Adrian_Kosowski and thank you for taking time to report this issue.

Can you please confirm if you are able to reproduce this behaviour in a different browser and an incognito windows? I don’t seem to be able to reproduce it on my end.

Apologies for the inconvenience when trying to upload the screenshots. As a new user, you are only able to attach one image per post. I have now manually moved you to a new level so you can now include more than one attachment in the Forum

It would be super helpful if you could record a screencast help us investigate this behaviour. We usually recommend using Loom, a great app for video screencasts: https://www.useloom.com/

In your video screencast, we recommend that you use a Chrome Incognito window and have your Javascript console open:

Try to include the entire browser window, including URL bar, in the video screencast.

Briefly describe (1-2 sentences) the Bug you’re experiencing:
As I click through the months the size of the box jumps around according to the number of weeks in the month. A minor annoyance to have to shift cursor to continue clicking through to the next month.
Steps to reproduce:
In list view click “Due Date” box. Click left or right through months.
Browser version:
Chrome Version 80.0.3987.122
Upload screenshots below:

Hi @Ayal_Shachar and thanks for the report!

This is a know issue, I’ve gone ahead and merged your post with this existing thread we have on this topic. Hopefully this is something we can fix soon :sweat_smile: I’ll keep you posted here as soon as I have an update!