Subtasks not re-created/disappear in repeating task



Subtasks are not showing up in a repeating task. I think this is a bug, because it worked previously.

Repro steps:

  1. Create a task
  2. Create several subtasks within the task
  3. Set task due date to today (subtasks have no due date)
  4. Set task to repeat periodically, 1 day after completion
  5. Mark task complete
  6. Duplicate task is created with due date of tomorrow

Expected/previous behavior:
The same subtasks exist in the new task

Actual behavior:
Only some subtasks exist in the new task

Unsuccessful workarounds tried:

  • Manually copy original task, and try again with the copy
  • Create entirely new task, retype everything, and retry same steps with new task

This just started happening last week. I cannot discern why certain subtasks are duplicated, and why others are not. Some of the original subtasks have descriptions in them, some have subtasks within them, and some have neither. None of them have due dates.

I use this scenario for a daily checklist of things that need to be done for my personal care (I have a physical disability) and things are being forgotten because the list is incomplete. Let me know if any further clarification is needed, and you are welcome to look into my account to investigate. Please help! @Alexis


@Amin_Lakhani I just tried it seemed to work okay for me.

Have you retried?

I setup a task with 6 subtasks and they all appeared.



I just tried it again and it seems to work now, just takes a couple seconds for the subtasks to populate on the new task. Thanks for trying it on your end!


Hi Jason, could you have someone else complete the task? That’s the situation I’m in, and the subtasks are again not showing up.