Sorting doesn't work inside the groups

I have two custom single-select fields. One used for grouping, another for sorting. In the project task list I have all tasks grouped by first custom field, however they are not sorted by second field inside the group.
When I turn off the grouping and sort them by both fields this sorting works fine.

However I’d like group and sort tasks inside the group. Please advise.

1 Like

Hi @Dmitry_Zakharchenko , welcome to the forum :wave:

Are you able to share a screenshot?

Generally, you can use the Group by button to create ‘sections’ in your List view. And then use the sort button to sort eithin those grouped sections.

If you are apply a subgroup in the Hroup by button, that will simply create subsections in your List view, it won’t sort tasks.

This is happening to us as well.

We are grouping by 2 custom fields and then trying to sort by a third. It says it’s sorting/reverse sorting, but nothing changes.

Here are the “Group By” selections:
image

Here is our “Sort” selection:
image

@Dmitry_Zakharchenko - I’ve moved this bug over to the Bugs - Asana Forum portion of the forum, since it seems the same issue is happening in several of my client accounts and it does seem to be a bug.

@Richard_Sather - I’m new to the process of moving posts. Do you know who we are supposed to @mention here?

1 Like

Sure, @Bryan_TeamKickstart !

That would be the amazing @Vanessa_N :slight_smile:

1 Like

Here is the screenshots:
Group by:


Sort by:

Result:

Hi @Dmitry_Zakharchenko , thanks for sharing those. That clearly looks like it’s not the expected behaviour of this recently launched feature!

Hoping @Vanessa_N can escalate this :pray:

2 Likes

Hi everyone, thanks for flagging this. I’ve been able to reproduce this issue on my end, so I’ve escalated the case to our Developers for investigation!

2 Likes

Thanks @Vanessa_N !

Hi everyone, our Developers have confirmed that this issue has been fixed! I’ve just tested on my end and the sorting seems to be working fine now :slight_smile:

2 Likes

Excellent, thanks for the fast turnaround, @Vanessa_N

1 Like

Thanks, guys. The sorting now works better, but I still have some issues. Please see the screenshots below.

@Dmitry_Zakharchenko could you check if these options are correctly ordered in the field option list (if they’re not, you can drag/drop to re-order). I believe that single/multi-select fields get ordered based on how they appear in the option list.

3 Likes

Thanks a lot, guys! I have reorder this in the option list and now it works perfect!

2 Likes