Sort tasks in Calendar View for My Tasks by due time + completed task at the bottom of the list

Briefly describe (1-2 sentences) the Bug you’re experiencing: calendar view doesn’t appear to be sorting tasks by due time - super troublesome, guessing this isn’t the intended functionality. Both in the awesome new week view, and month view

Steps to reproduce: view my tasks in calendar (mix of tasks with and without due times)

Browser version: Chrome Version 93.0.4577.63 (Official Build) (x86_64)

Here’s another user that has the same issue

Thanks!

3 Likes

We are also experiencing this issue and it’s very troublesome for us!

Hi @Jillian_Adkins, @Theresa_Walenta, thanks for reaching out!

Currently, this is expected behaviour and not a bug. Our Product team will work on some iterations for the 7 day Calendar view in the future and we hope to implement some filters and due time sort to this view too! :slight_smile:

You can keep on eye on the main thread for any updates: Plan your week with the new 7 Day Calendar View in My Tasks!

After they launched their new 7 Day Calendar View we have a problem:
“The missing order by due time is very crucial to us! Currently a task due at 8 AM can be at the very bottom of the day while the one due at 5 PM is at the top.
Now our team members have to manually rearrange their day over and over again, because it is not sorting chronologically by due time at the top of the day anymore. We would greatly appreciate a fix on this issue!”

That’s a huge problem to work…

Asana is doing something urgently to correct that ?

3 Likes

@Johan_MORIN - letting you know I submitted this in the Bugs section, hopefully that will get their attention sooner.

You can view/comment on it here: Calendar View not sorting tasks by due time

This probably shouldn’t have been released before having the sorting feature completed.

Otherwise, it’s a bit half-baked as it stands.

2 Likes

@Rebecca_McGrath it’s expected behavior in the month view as well?! That’s why I reported this as a bug. Previously, month view included sorting by due time, and now it does not. Please advise.

1 Like

You have to be kidding, how can it be “expected behaviour” to have total disorder in our days ? It was automatic before you did what you did with the 7 day. The problem is both in 7 day and in month view.
It seems like you don’t use Asana, please ask someone from Asana who really use Asana. I’m sure they forgot something and are happy with the new release but it is more a problem than a solution.
I think you have to fix it urgently not in some weeks, or let us go back to last version and when the new one is ready then make the actualization.

1 Like

Hi all :wave:t2: I can confirm that our Product team hear your feedback and frustration. They are currently working on ways to improve this feature. I’ll let you know as soon as I have any updates :slight_smile:

I see that it has been fixed in month view - thank you for that! (Would love it in week view as well, but at least month view is working like it used to.)

Last week, my Asana app upgraded (web app for desktop), and now my uncompleted tasks are no longer sorting to the top. This made me miss a task. Is there a setting where I can turn sorting uncompleted tasks to display before completed tasks? That would be preferred.

I was coming here to post about this. This is a super crucial feature for me and I don’t know why it was removed in the upgrade :frowning:

I logged on this morning and saw that Asana had upgraded and it looks great. When I went to complete a task, though, I realized that the completed tasks aren’t sorting to the bottom/incomplete to the top like they usually do? This is a really crucial feature for me, and I was confused why it was removed in the new upgrade. Maybe it’s not a bug and was intentional, but I wanted to flag it just in case. Here is another person who just posted about it, too, in the feedback section: Sort uncompleted tasks to the top of the list.

Steps to reproduce: Go to My Tasks in Calendar view and complete a task. It will not sort to the bottom as usual.

Browser version: PC browser version, Chrome 93.0.4577.63, up-to-date.

Hi @Sarah_Baker, @Hannah_Bernstein, thanks for reaching out! :slight_smile:

Can you please confirm if you are referring to tasks sorting in the My Tasks calendar view or another type of view?

Looking forward to hearing back from you :slight_smile:

Hi @Rebecca_McGrath I primarily use the calendar view, and that’s where I noticed the change. Thanks for your response!

Sarah

@Rebecca_McGrath Sorry, I should also have specified that it’s the My Task list in Calendar View.

@Rebecca_McGrath yes, it is the My Tasks list in Calendar view. Thanks!

@Rebecca_McGrath This is behaving as expected for me now. Thanks for the quick solution!

Hi everyone, thanks for taking the time to report this issue and sorry again for the trouble!

Our product team has confirmed this issue should be fixed now. We reverted the change to month view that had the tasks show up in a new order. This means that if you rearrange tasks in week view, it won’t change the order of tasks in month view.

We’re going to start considering other updates to make your calendar more customizable depending on your workflow. Stay tuned for more updates in the future!

2 Likes

thank you!! Can confirm it’s fixed. I so appreciate the quick response & troubleshooting, now my beautiful Asana calendar is back the way I like it :smiley: