Slack Rules break on Projects created from Templates

Briefly describe (1-2 sentences) the Bug you’re experiencing:
I’ve created a rule on a project template that sends a direct message to a specific user when a task is overdue. However, when creating a project from this template, the Slack action in Rules says “This action is no longer valid. Please remove it and try again.”, and as a result the Rule is broken.

Steps to reproduce:
As above

Browser version:
Firefox 93.0

Upload screenshots below:
As seen in Project Template:


As seen in Project created from template:

1 Like

Hi @Matt_Clark, thanks for reaching out! Let’s try to solve this together. Could you confirm what is the trigger that will trigger that action? For example, if you would like this message to be sent when a custom field is updated. Have you tried removing the trigger and add it again?

Looking forward to your reply!

@Emily_Roman just tested and I get the same result. Seems like the Slack integration doesn’t, er, integrate on a project instantiated from a template. It won’t even load the options (see attached).

I uninstalled slack from the project and reinstalled. Nothing
I am able to add the rule from scratch and it works, but obviously, that is not ideal.

Maybe the rule is being added to the project before the app is thus nothing to connect to and erroring out?

1 Like

Hi Emily - in this instance I have used a “Task Overdue” trigger connected to the “Send direct message” Slack integrated action. Though I suspect any trigger may cause the same thing to happen - seems to be related to the Slack integration.

By removing and reapplying the Slack integration on the project created from the template it will work again, however this is obviously not a viable solution for a project template that is used 10-20x a week.

@Getz_Pro Thanks for your help in reproducing the issue.

Hello Matt,

Was there ever any fix for this issue?
I have just run into the very same issue when using a template created in Asana with a Rule to notify a channel in Slack.

Would love to have this resolved!

Cheers

2 Likes

Hi @Stephen_Ford, thanks for reaching out! I’ve gone ahead and sent your report to our Product Team. In the meantime, you should be able to solve this issue by removing and reinstalling the Slack integration in your new project. I’ll post updates in this thread as soon as I have more information!

This is very problematic @Emily_Roman. The person creating rules in templates is often not the person using the template. The person using the template is often overlooks the rule being broken. I am often having to tell clients ‘oh, you have a rule broken in that project’ on projects that have been in-flight for months.

2 Likes

Hi Stephen,

Unfortunately it still appears to be unresolved at this time.

Fingers crossed there’s a fix in the works :slightly_smiling_face:

Hi everybody who’s facing to this issue and @Emily_Roman
I’m facing to the just same issue which is following:

  1. apply custom rule w/ sending Slack message in a project template
  2. create a new project with the template
  3. rule broken at sending slack message stage

even in my case, removing and reapplying the Slack integration doesn’t work at all.
I’ll catching up this thread and I’m really looking forward to solve this problem, not a deleting and reinstalling solution but real solution that there’s no need user action.

1 Like

Thanks for reporting this issue too, @DongWon_Sehr! Our Product Team is currently investigating and hopefully it will be solved soon.

@Matt_Clark @Getz_Pro @Stephen_Ford @DongWon_Sehr, our team has requested some extra information, could any of you help us confirming the following please?

  • Are you clicking the “Use Template” button to create the project or are you duplicating the project from the project menu?

Screen Shot 2022-01-07 at 16.25.52


Screen Shot 2022-01-07 at 16.26.55

  • Could you confirm if you created the Template Project or are you creating a new project from a Templated created by someone else?

If you didn’t create the template, the issue could be that you haven’t authorized the Slack app before and the Rule is automatically broken when you create the new project. We will investigate further once we have your confirmation! Thanks for your patience so far!

@Emily_Roman I always use templates via one of the 3 ways to use it. Use Template, + next to teams or within the team New Project.

Just confirmed, created a project via the Use Template and rules for Slack are broken.

Happy to share with support the template for testing.

Thank you for take care of this issue, @Emily_Roman
This is my answer.

Q1. Are you clicking the “Use Template” button to create the project or are you duplicating the project from the project menu?

A1. I and my team always create a new project with the button “Use Template”. Never duplicate for creating a new project.

Q2. Could you confirm if you created the Template Project or are you creating a new project from a Templated created by someone else?

A2. following 2 cases all doesn’t work.
case1. template creator : someone else / new project via the template creator : me
case2. template creator : me / new project via the template creator : me

Thanks for providing this info! I’ll share everything with our Product Team and I’ll circle back once I have an update!

Briefly describe (1-2 sentences) the bug you’re experiencing:
Usually once a week or so I have one of my rules break due to the Slack integration of sending a channel message. It seems that there is an issue on the backend with either Asana or Slack.

Steps to reproduce:
I am unable to detect what is causing this to happen. I don’t believe it is an issue on my end and it seems to happen with no rhyme or reason.

Browser version: 96.0.4664.110 (Official Build) (arm64)

Upload screenshots below:
Broken Rule - Slack Integration

Hi @Garth, thanks for flagging this!

Could you please deleting the Rule and recreating it and let me know if this resolves the issue?

If not, please try uninstalling and reinstalling the Asana + Slack integration.

Looking forward to hearing back from you :slight_smile:

We already have a thread on this topic so merging your post with Slack Rules break on Projects created from Templates to consolidate reports :slight_smile:

Hi @Emily_Roman ,

To answer your questions:

  • All projects are created through the Use Template button, never duplicated
  • I created the project template and associated Rules
  • However, I was not the one who authorized the Slack app in our account, though I can definitely see that it is authorized
  • The Slack integration works if it’s applied to a project, or re-applied to a broken project, it just doesn’t seem to work with projects created from templates, regardless of who is creating the project.