Rules with integrations do not copy over when using a template

Many of my project templates have several rules built into them – I noticed that any of the rules using integrations become broken on the new project when the template is used to create it. In order for them to become active again, I have to go in every time and reconnect the rule. Is there a way around this that I am not seeing? Thank you!

1 Like

Hi @Jaqueline, thanks for reaching out and reporting this issue! Please note both the user who owns the original rule and the user who is duplicating the project need to have authenticated with the Slack app, in order for the rule duplication to work. If this is not the case then it won’t duplicate correctly, and this is the expected behavior currently.

You need to authenticate Asana in your Slack channel from the Integrations tab in the channel settings:

You need to authenticate Slack in your Asana project from the Customize menu:

Let me know if you still have any issues after authenticating Slack and Asana!

Thank you so much! I’ve added the Asana app to the channel and confirmed that the Slack app has been added to the project template. All of the rules belong to me, and the project is being duplicated by me, through an automation set up via Flowsana. Is there a distinction between duplicating the project vs. using the template?

After confirming the above, I then created a test project, but am still seeing that the rule is broken. I’ve attached a screenshot. Is this better served as a bug report?

Hi @Emily_Roman

This is simply not the case. We posted this defect before and I just tested again after reading your post. I own the template, I own the rule, I own the connection to Slack and when I created a project from the template, the rules are broken.

New Project Today: Log in - Asana
Template: Log in - Asana

1 Like

FYI Flowsana’s duplication uses the “duplicate a project” API call, which by my understanding is doing the exact same thing as when you do a “duplicate project” in the Asana web interface, so the Flowsana-related piece of it shouldn’t matter, at least as I understand it.

1 Like

Thanks for confirming, @Phil_Seeman!

@Jaqueline and @Getz_Pro I’ll provide these details to our product team in the current bug we have opened for this issue. I will let you know once we have an update. Thanks in advance for your patience!

1 Like

Thanks, Emily! Is there a place where we can follow the progress, or is that only accessible internally?

Hi @Jaqueline, the bug is currently only accessible internally but I will post any updates in this thread as soon as I have more information. Thanks for your patience!

1 Like

Hi everyone, our product team has confirmed this issue should be now solved. Please let us know if the issue persists or if you have any other questions.

Have a great day!

2 Likes

This topic was automatically closed after 3 days. New replies are no longer allowed.