Remove duplicate task title when using forms

In Form settings,I have selected a field in my form to be used as Task Title, but even if I switch off “Copy all responses to task description” that field and response still shows up in the description of the created task. Can that be switched off somehow? Because it just duplicates information which is a bit annoying.


Hi @Dominik_Hamann, thanks for reaching out! It seems the question is still connected to the task description. Could you open the question in your form and click “Connected to”? In this section you will be able to remove the field from the task description and map it to a field in your task:

I hope this helps! :slight_smile:


I have the same question too, but I think it wasn’t clear what was being requested.

We’d like to uncheck the Task Title field in the Connected to field dropdown because we’re using that field in settings as the title of the task so there’s no need to repeat it in the Description. As requested, the desire is to not map it anywhere else.

That’s a bit of an edge case because at most one single field, the one used for the task title, would be unnecessarily in the Description.

But another case I’m facing is: I have a branching question that’s a multi-select with many checkboxes. Checking a checkbox opens up corresponding field/s. I’m actually not at all interested in seeing that huge multi-select field in the Description; I’d like to remove that from the connected mapping because it’s just effectuating the branching; the data I want is in the fields that appear when checked, and those I leave mapped to Description.

Hope that clarifies.

I’ve unmarked the Solution as a result!




Exactly. Once a field is selected as “Task Title” it should not be mapped anywhere else (but now it is mandatory to do so). The content doesn’t need to show up in the description or any other field anymore. Also agree @lpb description of multi-select though I haven’t really used it extensively yet.

1 Like

Hi @lpb and @Dominik_Hamann, I investigated this further with our product team and it is working as intended. “Copy all responses to task description” means that all responses will be included in the description (even ones that are mapped to a custom field). When that option is disabled, the answers explicitly mapped to the task description will still go there. For example, in this case the Task title question is mapped to the task description even if you selected this question to be the task name.

If you don’t want the questions to appear in the task description, you would need to map them to a field.

I’m moving this thread to the #productfeedback category so we can consider this in future improvements!

I hope this helps! Let me know if you have any other questions.

1 Like

Understoo, @Emily_Roman, but did you forget to move this to #productfeedback? When you do I’ll vote!



In understand that this is how it is designed today, but that does not solve the issue that information (by design) is unnecessarily duplicated. By selecting any response as the title of the task, it is already mapped to a field. Right now, you have either to select another field to map or it will show up in the description (as standard field). This could be solved by just making “Task Title” a selectable mapping field.

Ops, my bad! Thanks for flagging, @lpb. Done! :white_check_mark:

1 Like