Projects and Tasks not loading

@Gregory_Frazier-Hans and @Ryan_Sakry,

I’ve just requested an update from our engineers and will share it with you as soon as I get it.

I’m aware this is disturbing your team workflow and rest ensured that I’m doing everything I can to get his resolved. Thanks again for your patience and cooperation.

Wanted to update you on something. We tried an experiment, to create a new Project and moved over only 50 tasks. Same exact problems. Log in - Asana is the new Project.

HI folks,

Our team pushed a fix just a couple of hours ago, this should resolve the loading issue you’re running into. Could you please let us know if the issue is resolved on your end?

We look forward to your reply!

@Marie It looks like our projects are good. But we are all having our “My Tasks” areas locked. We have to use the Advanced Search feature just so we can see what tasks we are assigned to. Again we have tried clearing cache and multiple browsers. To no avail.

I spoke to soon it projects just went away again.

@Gregory_Frazier-Hans, can you give this another go? The fix was pushed only 10h ago, so looks like it wasn’t yet available when you commented last on this thread! looking forward to your reply!

Still having issues accessing multiple projects and members still locked out of their “My Tasks”

1 Like

Thanks for the quick follow-up @Gregory_Frazier-Hans, I’ve followed-up with our team and will update this thread as soon as they come back to me!

Marie, thanks for the updates. It seems whatever you did on Thursday made a positive impact for most of the day. Ended the day with issues again. Today seems to be pretty good. I have some people not having any issues, some with random. My tasks seemed to have cleared up as well after about 1 PM CST. Hopefully, we can keep it here going forward. We will update you again after the weekend.

1 Like

Our team believed the problems you experienced after they pushed their fix was linked to some cache on our end, but they’ve told me that this should be resolved by the end of the day, but I look forward to your update on Monday!


So far we have not seen any issues since about 2 PM CST on Friday, this includes the My Tasks issue mentioned here: Cannot Access "My Tasks" - #23 by Daniel_Williams

Thank you much for you and your dev team’s efforts.

Fantastic news @Ryan_Sakry, I’m so happy we worked it out together! Resolving issues like that takes a great team, but it also takes patient and reactive customers like you, so thanks for being so patient and mindful!

Here is a quick insight into what happened on our end:

  • The task I created to report your bug was followed by 22 Asanas from various engineering teams
  • The task currently has 66 comments and more likes than I can count!
  • 8 subtasks were added to the parent task
  • We even created a Slack channel to be able to work simultaneously on this bug

From our team to yours, thank you!

1 Like


We are experiencing the same task loading issues with a large project with over 1000 tasks. We use Safari. Can your devs look in to our logs and fix this. We have had no issues for the past years and this is something that started to happed last year in September. Thank you so much.

Hi @Rafay_Farooqui,

Can you please reach out to our support team with the following info, they will be able to take a look into this for you!

  • URL of the project that you struggle loading
  • Screenshot of the results you’re getting when running this test:
  • Can you confirm if your project is sorted (by due date or Assignee for example) or if it has any filters?

Answering these questions will help speed up investigations :slight_smile: Hopefully this gets resolved soon!

My home page and inbox will not load and I have been lock out of a My Tasks and a project where I’m the owner. When I request access it gets assigned to me. This is occurring through the browser and desktop app, but not on my tablet or phone.

A post was merged into an existing topic: Permission issue - “Looks like you need access to this task. Would you like to send a request to the owner?”