Project Workflow: Automatic due date is not set despite workflow rule

Important note: To help us resolve your issue as quickly as possible, please ensure to fill out all the sections below. Do not share any private information such as email addresses or phone numbers - This is a public Forum!

Briefly describe (1-2 sentences) the Bug you’re experiencing: When the due date of an incoming task (generated by a form) in a project is set automatically by a rule in the project’s workflow, it does currently not work anymore. In my case, the rule is “set due date 0 days in the future” which translates to “today”.

Steps to reproduce: Go into any project, click on “workflow”, and for any given section, edit the rule for setting the due date.

Browser version: Safari

What version of Asana are you using (Basic/Premium/Business/Enterprise)? Business

Upload screenshots below:

HI @Manuel_Frei , welcome to the forum :wave:

I cannot seem to replicate your issue. Could you click into the ‘Set due date to today’ part of your rule and provide a screenshot of your rule. There must be something wrong with the trigger.

Does the rule run when you simply add a task manually in the section? (i.e. NOT from a form?)

For a form’s intake, you may need to add a trigger above your workflow’s section as so:

1 Like

Hi @Richard_Sather, thanks for your quick response. Please find the screenshot below.

The rule does also not run when I add a task manually instead of using the forms. However, the two other defined rules as per my prior screenshot, “Add 5 subtasks” and “Assign to Person XY”, do run - both when using a form and adding a task manually.

I also tried what you suggested and added the trigger “Task is added to this project”. With this, it results in the same situation: the due date is not automatically set, but the two other rules do run (both with form and manual task creation).

This workflow used to run as it should for all three rules up until one week ago or so.

Hi @Manuel_Frei , thanks for the in-depth reply.

I was actually going to ask whether the other rules were also firing or not…
So, since it appears they are, it means the trigger is correct. Therefore for some reason the action to set the due date is not working. Again, I cannot seem to replicate this so please try the trouble-shooting steps below and let us know!

  1. Try refreshing your browser
  2. Try using a different browser (Edge, Chrome, Firefox etc)
  3. Try using an incognito/private window
  4. Try clearing your cache and cookies
  5. Try using Asana on a different network (Wi-fi or Cellular)
  6. Open to see if you get any errors
  7. If the issue occurs on the Desktop App or Mobile App, try uninstalling and reinstalling

Alternatively, if it’s not too much trouble, try to delete the section and re-create it. Then use the newly created section in your rule.

Hi @Richard_Sather, thanks for providing some trouble-shooting steps.

Here’s what I have found:

  • The issue does not persist in other browsers (e.g., Safari)

  • However, for Chrome, I tried deleting the cache, refreshing the browser and using an incognito window - nothing of these worked and the issue remained.

As I am using the Chrome browser as my default for several reasons, do you know how this could be resolved for Chrome?