Problem adding team member

I am having a problem adding a team member using the basic account of Asana!
Most team members have an email address with domain The one I am adding is instead I already addded a person with the latter domain (which shows up as guest), but I cannot add an additional one.
Could you help me out, please?
Thanks in advance

Hi @Riccardo_Marin welcome to the Forum! How are you trying to add this person? just in the team? Is it coming up with any error message?

Hi @Riccardo_Marin , welcome to the forum :wave:

Apart from answering @Danielle-GenD’s useful questions, you may also want to check in your Admin Console how many users (members) you have added to your Asana space.

The limit for Asana Basic (legacy) is 15 users. If you created the space recently (after Nov 2023), then you are likely on the new free tier called Asana Personal which now has a max of 10 users. You can read more below, here:

Also, if you’ve setup an Organization, I’m fairly certain that you cannot invite Guests on an unpaid plan; either the legacy Basic plan or the new Personal plan.

1 Like

Thanks, both of you!
So, I have the Basic plan that was setup some time ago and can add up to 15 members. Indeed, when I go to manage my team members it says that I have invited 6 out of 15 people.
I work in a university and we have different email domains: and being the ones I am dealing with here.
I am sending invitations through the Members panel of one of my teams. I tried just now to send the invitation directly from a project and for wathever reason it worked…I tried that way also yesterady without success.

In any case, if you know what might be the problem it would be great to know. When I send the invitation to join a project I see an alert message that says to be careufl inviting people outside of the domain. Should I get in touch with the IT dpt of my university and ask them to include as a trusted domain?

Thanks once more!