Private Project Task not showing Custom Fields when Mulit-Homed as a Subtask


#1

Briefly describe (1-2 sentences) the Bug you’re experiencing: We have a need for our Subtask to have Custom Fields. To accomplish this we have created two projects Public Project and a Private Project. We give everyone access to the Public Project and only one person has access to the Private Project. We add the custom fields to the Private Project. Then create a Private Task on the Private Project and a Public Task on the Public Project. We then multi-homed the Private Task as a subtask to a Public Task. When the owner of the Private Project views the Private Task by navigating through the Public Task, they can see the custom fields. However, users without access to the Private Project can access the Private Task through a subtask of the Public Task, but cannot see the custom fields on the Private Task.

Added to this, we have been doing this setup since May of 2018 with two other projects. We just noticed that all but one of the custom fields were showing on the Private Task when viewing the Private Task as a subtask of the Public Task, even though these users do not have access to the Private Project.

It appears there are some inconsistencies here and might relate to the bug reported yesterday ( Asana Crashes/Disconnects when making a change to a “comment-only” multi-homed subtask). I know this is confusing. I will be open to do a screen share to show the setup.

Steps to reproduce:

We are getting the same results if we are doing this manually or through the API (API Steps in Brackets).

  1. Create a Private Project (Private Project)
  2. Create a Public Project (Public Project)
  3. Add Custom Fields to Private Project
  4. Create a Public Task task in Public Project [Create Task through API].
  5. Create a Private Task task in Private Project [Create Task through API setting parent to GID of Public Task and project to GID of Private Project].
  6. Multi-Home thePrivate Task in Private Project to Public Project [Done via API in step 5]
  7. On the Public Project, move the Private Task to a Subtask of the Public Task [Done via API in step 5]
  8. As another user who has access to the Public Project, view the Private Task through a subtask of Public Task.
  9. The Custom Fields don’t appear on the Private Task when viewed as a subtask.

Browser version: Chrome 71.0.3578.98

Upload screenshots below:

This screenshot is someone who has access to the Private Project and Public Project viewing the Private Task as a subtask of the Public Task:

This screenshot is someone who has access to the Public Project but not the Private Project viewing the Private Task as a subtask of the Public Task:


#2

Just some additional information. The Custom Fields show up on the Private Task viewed as a subtask through the Public Task if there is data in the Custom Field.

However, the user who has access to the Public Task cannot edit the Custom Fields of the Private Task.


#3

Hi @Benjamin_Ragan :wave:t3: Thank you so much for reaching out and for taking the time give us all the details, we really appreciate it!

Quick question, on your first screenshot, I can see that the “Public task” is not multi-homed with “Test Recording List project”. Could you try to multi-home the “Public task” in “Test Recording List project”.

Once you do this, can you verify that:

  • The user who has access to both projects can see custom fields in the “Private task” subtask
  • That user with access to the Public project only can’t see the Custom Fields

This will be super useful to help us investigate further! Thank you so much for your patience and cooperation :slight_smile:


#4

@Marie:

Thank you for getting back to me. I have executed the requested test.

  • The user who has access to both projects can see the custom fields on the “Private Task” subtask after Multi-Homing the “Public Task”.
  • The user with access to the Public Project could not see the Custom Fields on the “Private Task” subtask after Multi-Homing the “Public Task”.

Hope this helps.


#5

Thank you so much @Benjamin_Ragan;

I’ve reported the issue to our Development Team and I’ll be in touch as soon as I have an update. Thank you so much for your help and patience!