Outlook desktop add-on worked before but isn't anymore

Hello — I am having similar problem. It is not allowing me to click on my Asana Addin to add tasks directly from my Outlook. It worked fine a couple of weeks ago. Here is the error I get.

Sign in

Sorry, but we’re having trouble signing you in.

AADSTS750054: SAMLRequest or SAMLResponse must be present as query string parameters in HTTP request for SAML Redirect binding.

Hi @Rafael_Chavez,

Could you try logging in your Outlook mailbox from an incognito window; are you having the same issue when using the add-on?

Could you also provide us with a screenshot of what you’re seeing? Looking forward to your reply!

Hi — When i log into my Outlook mailbox from a browser, I dont see the option of the addin. The issue is only through my Outlook desktop app add-in. Here is the window I get when I try to create a task from an email, using the addin.

What is interesting is that I am able to connect on certain levels. For example, when I am assigned a task. The add-in allows me to utilize the action buttons. See snapshot. Capture

Hi Justin, I ran into this issue today, Have you got Protected Mode enabled in Internet Options ?

This fixed it for me (outlook may need to be restarted)

1 Like

Hi – Any update to this?

Hi @Rafael_Chavez and apologies for the delay in responding to you!

The last screenshot you shared is not part of the Outlook integration, it’s something completely separated called Actionable messages; it is an option actually built by Microsoft that can be enabled for other products than Asana too (More info here https://developer.microsoft.com/en-us/office/blogs/actionable-messages-for-connectors-and-email-now-in-preview/ and there https://blog.asana.com/2018/05/asana-outlook-integration-updates/). This was launched before the Asana add-on for Outlook, but the latest is way more powerful.

Back to your issue with the Asana add-on, from what I can see in the error message of your first screenshot, it looks like the issue has to do with your SAML logging. Are you the only one experiencing the issue, or do you have colleagues with the same problem?

On another note, the web and desktop add-in are completely separated and need to be installed separatly. Could you try the following?

Desktop: try to uninstall the add-on following these steps; what happens when you re-install it? (I have added the steps to install on desktop just below:

  1. Click the red store icon on the Outlook Desktop app (for 2016 version or later)
  2. Select “Manage add-ins” from the menu
  3. Search for Asana for Outlook
  4. Click “Add”

Web: When you click on this link: https://appsource.microsoft.com/en-us/product/office/WA104381833?tab=Overview, do you see “Get it now” in the top left corner?

One last thing, I’ve moved your messages to a separate thread to easily follow-up on your specific issue, hope you don’t mind.

And apologies for the long reply, but I just wanted to be sure to cover all your questions :slight_smile: