Issues with Asana Login on Desktop PC

I am experiencing issues with the desktop login on my PC.

It’s running Windows 10.0.19045.

Here’s what I’ve tried so far:

  1. Cleared all cookies and browser history.
  2. Tried three different browsers (Chrome, Mozilla Firefox, and Microsoft Edge) – all updated to the latest versions.
  3. Restarted my PC.

However, none of these steps have helped. I receive the same error each time I attempt to log in. Interestingly, my login works fine on my iPhone app using the same username and password.

Has anyone else experienced similar issues, or does anyone have a tip on how I could resolve this problem?

Thank you very much for your attention and support. :blush:

Hi @Ivan_Zlatanchev, thanks for reaching out! I’m afraid I wasn’t able to reproduce this issue so it seems to be related to your Asana account or computer settings, I recommend you to contact our support team so we can have a look at your account setup and help you solve this asap: How to contact our Support Team :email:

When you contact them, please feel free to share the URL of this thread so you don’t need to repeat the information again.

Let me know if you have any other questions!

I think the main issue and the one everyone seems to complain about is the fact that the Desktop app does not have it’s own login form. The fact that when the app needs to login it will open an external browser for the login form and than have the credentials passed to the app by browser link is some of the most braindead incompetent programing I have EVER SEEN. I cant think of one other app that has this behavior and frankly simply adding a proper login form to the desktop app will most likely eliminate most if not all of these minor non reproducible login issues. Just Saying get rid of the external browser for logins and have the login performed in app it would be vastly simplified and far more stable

Thank you Emily for your kind reply. I would try to contact the support and see if they could help me.

I wish you a nice day!

Thank you Michael for your reply as well, I would contact the support and see if they could assist.

Many thanks Ivan

This topic was automatically closed 16 days after the last reply. New replies are no longer allowed.