IOS multiple photo upload issue


Since the recent iOS update and using the multiple photo upload, I can select one image and add it, but the photo never uploads.
I’ve tried the usual, restart, remove app and reinstall and updated to latest iOS version.

Anyone else had this issue and potentially solved it?
Thanks in advance!


Hi @Adrian_Marshall, I’ve just tried to reproduce this issue, but I don’t seem to have any issue uploading multiple photo to a task at once. Are you having the same issue using WIFI and mobile data? I’m just wondering if the issue is related to connectivity or to the app itself. I look forward to you reply!


Thanks for the reply. I did a little bit more testing. It appears it may be due to iCloud not downloading the photo. I can take a photo outside of the app and before it is uploaded to iCloud it will allow me to add it to a task. Not sure if this is a setting somewhere?


Got it! Sounds like you’re right; the photo is probably not considered as “saved” until it is synced with iCould which would explain why the Asana app can’t pull it to upload it to your task. Unfortunately, I don’t think this is something we can fix on our end; sorry for the inconvenience! :sweat_smile:


2 posts were split to a new topic: Upload picture from phone via the mobile app