How to add subsection in subtask?

So I know how to add sections to a project, but for a subtask, how do a add a subsection to it? I want to break it out further but not sure how to go about it.


Just type a “:” as the last character of your subtask’s name (same as for tasks); you don’t need to use the “Section” button for tasks, and there is no such button for subtasks, so maybe that’s the confusion. Or am I missing something? Hope that helps…


perfect, thank you! is there a list of short cuts?

Yes, click the Help menu (near top right of Asana page), then click Keyboard Shortcuts in the menu.

Hi, the “:” doesn’t seems to work for me, is this a premium feature?


1 Like

Hey @a11!

Sorry for any confusion caused here, we have recently made some changes and you can now add a Section it by simply using the “Tab+N” shortcut. You can also find more info in the following article: :grinning:

Hi, Why did you remove “:” function?
I mean not complain but just wondering.

Hi @onomotoharu and welcome to the Forum! :wave:

You can read about this change here: "Tab+N" our new shortcut to create Sections

Let me know if you have any follow-up questions. Have a great Friday!


hi there, this no longer seems to work. at least when i’m using chrome on my mac it doesn’t work

@Nila_McCann, The behavior has changed. Once you click in the subtasks area or create the first one, you can then click Tab+N to create a subsection there. See "Tab+N" our new shortcut to create Sections for more info.



This no longer seems to work. When I use Tab+N, no matter what I do, it now only creates the new section at the top level. Am I doing something wrong? Has the functionality of subsections been removed?

@Kevin_Vaughn, Are you clicking in the the task detail pane area first, like in the Description, before Tab+N?


@lpb, thanks for your reply. Yes I am. Every time it still creates the new section at the top level. I have used this command/feature in past projects with no issues.



Perhaps @Emily_Roman or @Marie could weigh in, or you could contact Support.

I just verified this works for me right now, and saw it working for a client during a screen share this morning as well.


Problem solved. I have to actually be clicked into a subtask and then click Tab+N, not just the subtask pane, for it to create a subsection.


After creating a subsection with TAB+N how do you delete it? I can’t find a way to delete this subsection.

@RoundRocks, You should be able to delete the Subsection the same way you delete a Subtask: select it and click “. . .” > Delete selected subtask or use Tab+Bksp.


There is no “…” and when you click or right-click on it, it just makes the title editable (unlike right-clicking tasks that give you a menu that has “delete task” in it) but TAB+Bksp worked.

1 Like

@RoundRocks, By “. . .” I mean the Task Detail overflow menu in the top right corner shown here:


Ahh, ok, that worked! (and it shows the shortcut too :slight_smile: ) Thanks.

1 Like