Form - "Connected to" Custom field mapping option not available; only "Add to task as"

I am fairly new to Asana and have search Guide, Help and the Forums but do not see any information on my issue.

I am trying to use Forms as map questions to custom fields per these instructions:

However, I do not see the “Connected to” option. Only “Add to task as” and the options there are New Field, Existing Field, or Task Description. Within Existing Field all the fields in my project are not available to select. This is very frustrating. What am I doing wrong or has the Forms functionality changed? If so, Asana should update the Guide and Help sections.

My form is using a lot of branches and some have the same question with different responses that I would also like mapped to the same custom field so that I can easily track all responses for the question in one column/field in my tasks lists, but this also doesn’t seem to be an option without overwriting other form question responses. I keep getting a warning when I try to do this.

Thanks for any help.

Welcome, @Natasha_Padilla,

Yes, the words used to describe the feature has changed, but not the underlying feature itself.

The reason you don’t see all existing project custom fields appear for every question is that they must correspond to the type of question in the form; so for a single-select question you’ll only see single-select type custom fields.

You can ignore that warning when you map questions in alternate branches to the same custom field; the warning is for when you might have mapped to the same custom field more than one question that might appear in the forum to a user.



1 Like

Thank you so much, lpb! I was able to accomplish what I needed to with the custom fields mapping for my form. I wish the Asana task layout I’ve customized in the list view of my project translated to my CSV export and/or Sync to Google Sheets, but I guess we can’t have it all. :slightly_smiling_face:

Happy New Year!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.