Dropbox not working on Safari

Dropbox integration is not working on Safari 13.0.3 (I can use it on Firefox and Chrome)
I tried deleting cookies and emptying cache, still not working.

I’m able to use it in Private Mode.

Attached you can find a video showing several console errors (Notes at the end of this post).
And this is the error showed in the console when I tried to access Dropbox integration:

[Error] Blocked a frame with origin “https://app.asana.com” from accessing a frame with origin “https://www.dropbox.com”. Protocols, domains, and ports must match.
ze (bundle.js:2:109390)
dr (bundle.js:2:154084)
(anonymous function) (bundle.js:2:166864)
unstable_runWithPriority (bundle.js:2:24455)
Or (bundle.js:2:166847)
Fr (bundle.js:2:166625)
Ur (bundle.js:2:165970)
Dr (bundle.js:2:165020)
Tr (bundle.js:2:164114)
enqueueSetState (bundle.js:2:190465)
(anonymous function) (bundle.js:2:21266)
(anonymous function) (bundle.js:2:10305033)
(anonymous function) (bundle.js:2:949546)
(anonymous function) (bundle.js:2:1018833)
runWithExceptionInfo (bundle.js:2:4318649)

Notes:
At the beginning of the video, the first errors appeared when I just enter the website.
Then, another bunch of errors showed when I clicked on the “Attach files from Dropbox” link/button.
And the third bunch of errors showed when I tried to login to dropbox from the popup window.

Hi @J114, the fact it is working in private mode indicates that an extension installed on your browser might be causing this issue. Have you recently downloaded a new extension? If not, one that you’re already using might have been recently updated and causing this issue. Could you try to deactivate or uninstall your extensions one per one and run some test to identify which one might be at fault there?

Hello Marie, still not working.
I just use two extensions, Grammarly and WhatFont, I disabled them, cleaned cache and cookies and tried again without success.

The console error is the same.

Thanks @J114,

I’ve gone ahead and filed a bug for our team to investigate and moved this thread to our #bugs:current-bugs category in case other users are running into the same issue. I’ll keep you posted here as soon as I have an update!

1 Like

Thank you very much, in the meanwhile I will use firefox for asana, but is not the most comfortable thing as I am a Safari user, I’ve got firefox and chrome just for testing purposes, all my daily work I do it with Safari.
Thanks!

1 Like

Hi @J114,

Could you let me know if you’re still running into the same issue? Our team was initially able to reproduce the issue but it seems it is now fixed when they refresh they cache and cookies. Can you give this a go and let me know how you’re getting on? Looking forward to your reply!

Not working for me on Safari. Like others, I’ve disabled all extensions, completely cleared the cache and cookies, and also tried in Private mode. I still cannot attach files from Dropbox; it gets stuck at the Dropbox sign-in pop-up: https://www.dropbox.com/s/l30vjex1rwxn7k6/Screenshot%202020-01-22%2008.55.59.jpg?dl=0

Hi @Marie,

I´m having the same issue as @Nypa-Loto. I can’t attach files from Dropbox Safari *I’ve tried clearing cache and cookies and also Private Mode. Safari version 13.0.4 . I have no extensions installed.

Same issue for me as well in Safari, latest version 13.0.4. Continue to get the dropbox sign in screen no matter how many times I try to sign in. Cleared cache, removed extensions etc. doesn’t work in private mode either.

Confirmed does work in Chrome. Hoping for a solution, thanks everyone!

Hi Jaime, just wanted to let you know that I received a message from Francesca from Asana that the team is working on the issue. Hopefully we’ll be getting a solution soon!

HI @Juan_Ducote and @Jaime_Casal1 and so sorry for the disconnect here. I’ve spoke to Francesca and pinged this bug to ask our team to take another look into it.

Would you be able to send me a screencast by DM? This would be super helpful to continue investigating on our end. In your video screencast, we recommend that you use a Chrome Incognito window and have your Javascript console open:

Try to include the entire browser window, including URL bar, in the video screencast.

Thanks again for your help with this issue!

Hello @Marie, this issue only occurs with Safari. I will send you a video screencast.

1 Like

Hey @Juan_Ducote, @Nypa-Loto, @J114

Could you do me on favor and clear your cache and cookies, and give this another go? Our dev team believe there is a good chance for this issue to be solved!

Thanks again for your patience and help here, I look forward to your reply!

Hi Marie, unfortunately I keep getting the same error. I’ll send you the screen cast by DM. Safari Version 13.0.4 (15608.4.9.1.3), private window, cleared history, cache, cookies.

1 Like

Thanks for the reply @Juan_Ducote, and yes a screencast would be super useful! Thanks again for your help here!

Hi @Marie
Just wanted to let you know that the issue has been solved, both dropbox and google drive are now working! Thank you!!

1 Like

Wonderful, thank you so much for letting me know!

This topic was automatically closed 16 days after the last reply. New replies are no longer allowed.