CSV Import Progress

Briefly describe (1-2 sentences) the Bug you’re experiencing: Apologies, I’m not sure if this is really a bug, user error, feedback, or maybe a feature request, so please feel free to redirect me if this is not a bug. When I go through the process of importing a CSV, it gives the indication that the import is in progress and slowly uploads each task. However, I’ve tried a couple imports today that never fully imported (waited approx 20 mins I think) and there was no way for me to cancel or check the import status to see what might be wrong. And if I clicked the X on the little notification at the bottom, I have no idea if it’s still trying to do the import. It may have to do with rules I have set in the project, but now when I try to duplicate the project and get rid of the rules, it seems to be timing out as well. It may be that I’ve just clogged up my queue, but I also have no way of stopping or clearing it.

Steps to reproduce:

  1. Import CSV on existing project with 15+ rules (that’s just what I have right now but might be timing out with less than this)
  2. Some of the rules influence fields that are also indicated in the CSV import

Browser version:
Chrome Version 79.0.3945.88

Upload screenshots below:
Not sure screenshots would help - I’ve already closed the notification of the import being in progress and now it’s just tasks with some empty fields

Let me know if I can provide more info. Thanks in advance!

Also, the import was only about 7 tasks.

Hi @Taylor_Cohen and thanks for the report, you gave us a lot of important info! I’ve a few more questions to help me isolate the isse:

  1. Have you followed these steps to set up your csv file? https://asana.com/guide/help/api/csv-importer#gl-tips
  2. Have you tried another csv (with different data), does the problem persist?
  3. Could you also try importing your initial csv in a brand new test project and let me if you can reproduce the issue?

Looking forward to your reply!

Thanks so much, @Marie! Here are my responses to your questions:

  1. Yup, I did follow those tips to organizing my data. The one thing I noticed that I wasn’t including originally was the Section/Column, but I just tried a new import with that included and it is queuing similarly.
  2. Just tried alternate data and had the same problem (it does seem to be working fine for a wufoo form I’ve connected to my Asana project).
  3. Just tried creating a project from scratch as well and have a similar issue happening.

Totally understand it’s a time of year when response might be slower, so no major rush on this. :slight_smile:

Thanks again.

Thanks for the follow-up @Taylor_Cohen.

In order to investigate this further, we’ll need help from our support team (they have access to more tools than we do in the Forum :slight_smile: ). Could you please reach out to them and share the following info:

  • The URL of this thread, so you don’t have to re-explain everything from scratch
  • The CSV file you’re trying to import, so we can try and reproduce on our end
  • The URL of the Asana project you were trying to import your CSV into

I’m moving this thread into #bugs:resolved-bugs in the Forum, but if you can, let us know what solution you’ve found with the help of our support team :slight_smile:

1 Like

Thanks, @Marie, will do!

1 Like

Update here - I believe we’ve figured out a solution thanks to help from the Asana support team!

Problem Identified: You cannot have a rule running on a field that you are also importing via CSV.
Example: If you have a rule in your project saying anything added to this project should also be marked as Custom Field Option, and you also have a column in your CSV that maps to that same custom field, the import may not be able to fully load.

Things to note:
All will work if you pause the related rules when you run the import
It will also work fine if you delete that column within your CSV before import
It does not seem to matter whether the value in your CSV is the same or a different value than what your rule is indicating - both cause issues

Hopefully that’s fairly clear, but let me know if I can provide any additional details or if screenshots would be helpful.

Thanks!!

2 Likes

Thank you so much for circling back and sharing the solution with us @Taylor_Cohen, I’ve learnt some things there, and I’m sure your post will also helpful to a lot to other users too!

This topic was automatically closed 16 days after the last reply. New replies are no longer allowed.