Could not connect service. I can´t connect IFTTT with asana

I was happily using IFTTT with google assistant for saving my tasks in Asana. But today it stopped working. There is a problem when I try to connect IFTTT to asana; it says: “Could not connect service.” I tried with a different asana account, and it happens the same. Any ideas?

Hi @JUAN_SERANTES and thanks for writing in!

Unfortunately, because we haven’t built this integration, it is difficult for us to help you troubleshoot and fix this issue. My guess is that IFTTT hasn’t yet updated to support our latest updates, which probably causes some issue. I would recommend reaching out directly to IFTTT support via the link at the bottom of this article: https://asana.com/apps/ifttt.

Sorry for not being able to help further here, but please feel free to reach out if we can help in the future!

@JUAN_SERANTES,

When you contact IFTTT, I would recommend pointing them to this forum post which discusses an Asana update now occurring:

Asana is moving from numeric to string IDs and that’s my bet as to why it stopped working. If I’m right, then note that it will start working again later today, as (per that post) Asana just changed it for 24 hours in order to surface issues like this one. IFTTT then has another 2 weeks to update their service before it breaks again for good on October 29th.

3 Likes

I’m having the problem too with a similar recipe I made and has worked great for a long time.

I submitted a request (#141991) but it’s one-way only; they don’t promise any reply.

It would be wonderful if some at Asana could apply some leverage; this must be a popular integration with Asana and all IFTTT/Asana customers are perhaps down at this point.

Thanks,

Larry

My recipe is working again, at least at the moment, even though IFTTT Activity log says it’s being skipped!

Hey Larry,

I’m sure that’s because the string-ID change was only turned on for 24 hours yesterday to today, to surface issues (like this one!). Now IFTTT and others have 2 weeks to fix things until it gets turned on for good on the 29th.

1 Like

Right. I hope Asana reaches out directly to such a major player who clearly is not paying attention on their own, and perhaps won’t heed random reports like mine (even though I included the specicic link you mentioned).

Yeah! Hopefully they already have.

cc: @Joe_Trollo @Ross_Grambo ??

1 Like

Hey @Phil_Seeman & @lpb,

I reached out to IFTTT about a month ago with the context of our string id change. Sadly, I never heard back.

I’ll go ahead and reach out again.

4 Likes

FYI, I set up an IFFT integration using Google Assistant and Asana. I used the phrase "Add a task to ", and then Google would create a task with the subject of whatever I said after the first bit (i.e. the value of the variable ). It added it to a designated project in Asana and tagged it.

Unfortunately, this has recently stopped working. There appears to be an issue with the Asana IFTTT service or system. I was wondering if anyone else had tried this or if there were any reports of issues with IFTTT.

It’s rather sad, as it was great to be able to walk around and just add a reminder via Google Home without having to pull out my phone and fuss around with it. I could also use Google Assistant, which was great if e.g. I was commuting and thought of something to add to the list.

@ElBeld, @Marie, This issue is also being discussed at:

and this post should perhaps be moved there.

Thanks,

Larry

1 Like

All done @lpb, thanks!

1 Like

Yep my recipe is working again too

This is the site for reporting issues in IFTTT https://help.ifttt.com/hc/en-us/articles/360025901754 I also have sent them an email to support@ifttt.com. If we all send them our concerns the possibilities that they are going to fix it increase. In another way, unless we do something, we are all going to lose this useful service that IFTTT is providing for us, who knows for how long…

1 Like

@lpb Care to share your IFTTT recipe link, as I couldn’t find any that serves this purpose.

@D11, Sure, it’s just: `If You say “task to self $”, then create task:

where the Assignee is oneself.

Hope that helps,

Larry

1 Like

Having the same issue – reported through their form & by email (thank you for the links @JUAN_SERANTES)

Here’s the note I sent for anyone that wants to copy paste:


Asana has had a breaking API change (switching to string IDs) and my recipes are no longer working to add tasks (Applet ID [insert yours here]).

Here are more details on the API change & comments from others expressing the same problem: Could not connect service. I can´t connect IFTTT with asana

3 Likes

Anyone heard anything? @Ross_Grambo?

@Amin_Lakhani,

Sadly I haven’t heard anything. I’ll try to reach their support again.

1 Like

Thank you for trying :slight_smile: