Hep needed - Asana integrations do not seem to work

I am a little stuck here and need some help. I am in talks with Asana Support, but they are just trying to send me away and I am not sure how to solve this.

Basically I seem to have a problem with Asana integrating with other apps. I am not sure if this is a problem with Asana or something else, but I need someone to help me, since my knowledge is limited.

So here is the issue.
We have Asana (guess you are not suprised here)
We have SSO with Google.

We tried to add Asana Bot to Google Chat
The bot was added successfully.
However when I try to click on the bot to authenticate in Asana, we are presented with the following:

There was an error processing your request.
Go back to Hangouts Chat and initiate the configuration again.

We tried to delete the bot, add the bot again, sign in and out of Asana, sign in and out of Google, use a different browser, use different computer - nada

Then I tried to integrate Asana and Automate.io.
Automate.io cannot call Asana and get any projects from Asana.

Then I tried Zapier, to see if there is an issue there.
I created a Zap between Asana and Google Calendar.
The zap is ok, but for some reason works some times, sometimes not. Nothing is changed and the response of the zaps that are not working:
While requesting “dev_method” from Asana we ran into an error: Javascript Exception: object: RefreshTokenException.
Troubleshoot error

Hi @IvanStaykov, thanks for reaching out!

Just to confirm I understand your issue, are you having issues connecting different integrations like Automate.io, Asana Bot and Zapier or are you having issues after you integrate them?

@Phil_Seeman and @lpb do you have knowledge about these integrations? Any help would be very appreciated :raised_hands:

Looking forward to your reply!

Hi @IvanStaykov,

This isn’t much help per se, but especially since these all look like authentication-related issues, I’m guessing the issues are all related to Google SSO.

I don’t know if this would be possible in your environment, but just for testing/confirmation purposes, would it be possible for you to disable Google SSO temporarily and try the connections again to see if they then work? Obviously that’s not a permanent solution; I’m just looking to see if you can confirm my suspicions.

1 Like

@Emily_Roman, I’m afraid I don’t have much to add beyond @Phil_Seeman’s suggestions. It would seem to be either Google SSO-related, or perhaps something specific to the organization



1 Like

Thank you all for the quick replies. The problem occurs after the actual integration, at the moment when the two apps need to authenticate / connect.

Basically all aps find Asana, the integration is “green” but the moment we need to authenticate, pull something, set up something we run into an issue.

I am investigating with all parties and will see if something comes up, but it may seem that indeed the SSO is the issue and not Asana.

Thank you anyway!

1 Like

Thank you so much @Phil_Seeman and @lpb! :star:

@IvanStaykov If you can, let us know what solution you’ve found. It’ll be very helpful!

Just to provide a little insight about things that aren’t the source of the problem:
I just added the Asana bot to my G Suite Google Chat this morning and it worked perfectly. Yesterday, I updated one of my Asana - HubSpot - Calendly zaps and tested and it worked fine. I’ve used Automate.io in the past (6-8 months ago). So, at least with the Asana bot and the Zapier connector, it seems to be working for me. So, I’m simply commenting to let you know that it’s working generally, so hopefully, as Phil and Larry said, … hopefully it’s isolated to being an authentication issue.****

1 Like

Ok an update:

  • we fixed the Zapier integration - not a real issue there. Zapier wants to use pagination, since we have too much data. However Zapier does not support the Asana paginations and both companies are not working on this integration, so the info is that there is a standstill in terms of new developments
  • we fixed the Automate.io integration, the issue was the same as with Zapier
  • the Google Chat problem has not been resolved, it is now escalated to Google and later further escalated to their development team.

I will provide more info as it comes available.

1 Like