Copy multiple tasks

tasks

#1

how do i copy multiple tasks at once including sub tasks?


#2

Hi @Stuart_Lisk

To copy multiple tasks, you select the first one by clicking on its title, holding down shift and selecting the last one. Or you can select non-consecutive tasks by holding down Ctrl.

The only way that I know of to copy subtasks is to add them to the project, which makes them appear outside of the parent task, or to drag them out manually, copy all of the tasks at once, then drag them back in again.

This only really applies if you’re copying tasks within the same project. If you want to copy tasks to another project, it’s much better and easier to multi-home them by adding them to more than one project.

Hope that helps.


#3

Hi @Stuart_Lisk! @Mark_Hudson is completely right there! Here is a little more info on multi-selecting (https://asana.com/guide/help/faq/multiselect) and copying (https://asana.com/guide/help/tasks/actions#gl-copy-tasks) tasks! Let us know if there is anything else we can help with!


#4

@Marie @Mark_Hudson I was able to select multiple tasks but do not see where I can select copy. How do you copy them once they are selected?


#5

Hi @Chris_Nordman

To copy, you just use the usual keyboard shortcut - Ctrl/Command + C.

:+1:


#6

Ha! Overthought this one, didn’t I? Thanks! This should be the last piece I need to get this going.


#7

This isn’t working for me. Nothing shows up when I paste the tasks.


#8

Hope you found a solution Christne but if not, it works if you use ctrl+c to copy then click to open a new task in the task list view to write and use keyboard shortcut ctrl+v it then pastes in all of the tasks you selected :slight_smile: It took me a while to work this out too!


#9

Hi Jennifer-

I can get the tasks to paste within the project where they already live, but not into a different project. So I’m having to copy, paste, select & drag to the new project. It seems like copy and paste should work across projects.


#11

Thank you posting this question and also for the helpful replies. My question with this is, when I copy the tasks, it removes my formatting. For example, once I copied the tasks, and pasted them into new task, it became four different tasks, instead of one with bullets as I intitially had them. Is there a way to turn off that formatting feature?


#12

@Marie Thank you for your answer. When I select multiple tasks, the “copy tasks” option is not there. How can I copy multiple tasks and keep the same information - assignees, due dates, subtasks, and etc?