Chrome Extension doesn't work - "Cannot connect to Asana"

Briefly describe (1-2 sentences) the Bug you’re experiencing:
Chrome extension doesn’t work. Every time I click on the extension’s Asana logo, I get the error message “Cannot connect to Asana - Be sure you’re logged in and connected”. And nothing else.

Steps to reproduce:

I signed up for Asana using a personal email address.
I am able to log in and use Asana through the web.
I installed the Chrome Extension. But clicking it I get “Cannot connect to Asana” (and besides the error message, nothing else shows up)

Possibly important note: I am using the Chrome “people” feature, and the Chrome Person I am logged in as is using my company email address (which is a google GSuite based email) which is different than my Asana login. Could it be that the extension is confused because it thinks I should be in Asana using my corporate google SSO which I am not?

Browser version:
Version 74.0.3729.157 (Official Build) unknown (64-bit)
In Ubuntu

Upload screenshots below:

Hi @eran and welcome to the Forum!

Sorry to hear you’re running into trouble with the Chrome extension!

You’re completely right, if you’re logged in in Chrome with your professional email address, you cannot log into the Asana extension for Chrome with your personal email address. To log in with your personal email you should switch to your personal “people”.

If you’re not able to log in with your professional email, please let me know and I’ll be more than happy to investigate this further for you!

Hi Marie, thank you for the very fast response.
I am trying out Asana using my personal email because I had issues connecting with my professional email (it sent me to my company’s SSO but then I got stuck because my company doesn’t currently officially support Asana).
Furthermore, I use Chrome sometimes using my work “people” and sometimes using my personal “people” - it helps me separate my workspaces better. If I understand correctly, this might cause problems if the extension is tied to the Chrome “people” being used…

Got ya @eran! Unfortunately I can’t access your account on my end, but if you want us to help you resolved the SSO issue with your work email address, feel free to reach out to our support team, they will be in a better position to help!

I have this very same problem; the differences are:

  • The extension suddenly stopped working after having used it for 2+ years
  • I only have one “People.” (same as my asana login)
  • I have uninstalled/installed several times.

What other issues may be causing this?

1 Like

This is the error I get in the inspector

index_prod.js:2 TypeError: Cannot read property 'id' of undefined
at t.<anonymous> (index_prod.js:2)
at l (index_prod.js:2)
at Object.next (index_prod.js:2)
at a (index_prod.js:2)
(anonymous) @ index_prod.js:2

Hi @Alex28,

Would you be able to send our support team a screencast of this issue to help us investigate? Loom is a great app for video screencasts: https://www.useloom.com/

In your video screencast, we recommend that you use a Chrome Incognito window and have your Javascript console open:

Try to include the entire browser window, including URL bar, in the video screencast

Thanks, clearing “All time” cookies and everything else fixed the issue.

2 Likes

Great news @Alex28, thanks for keeping me posted!