Asana is not loading and support link is also not working

Important note: To help us resolve your issue as quickly as possible, please ensure to fill out all the sections below. Do not share any private information such as email addresses or phone numbers - This is a public Forum!

Briefly describe (1-2 sentences) the Bug you’re experiencing: Asana is not loading, tried clearing cache, incognito, etc.

Steps to reproduce: Just went to and tried to log in several times.

Browser version: Chrome Version 120.0.6099.109 (Official Build) (arm64)

What version of Asana are you using (Basic/Premium/Business/Enterprise)? Premium

Upload screenshots below:

Problem: Asana is giving me a notification saying error, I tried reloading Google chrome and cleared cache and cookies. I tried clicking on contact Asana support but won’t work.

Steps to reproduce: Went to and tried to reload the page and login

Browser version: Version 120.0.6099.109 (Official Build) (64-bit)

Asana version: Basic

Hello @Celine_Benicarlo @David_Esau,

there was an outage yesterday so probably it was due to this:

Can you check now again please to see if it works?

1 Like

Hello, yes it started working again after a few hours.

1 Like