Calendar View not showing due dates

In the main calendar view (all project tasks) asana is showing no tasks. I also cannot add tasks to the calendar. It seems to be working when I am in a project, but this is not a useful way to see tasks in all projects. Please help!

Hi @Cristina_Bahr,

what exactly do you mean by “main calendar view”? Are you referring to the calender view in “My Tasks”?

Yes, that is what I mean.

Sooo, the calender in “My Tasks” just shows your own tasks, those that are assigned to you.

I think what you’re asking for is a calender that shows tasks from everybody from all projects?

If that’s what you’re looking for, its’s not possible.

No, not asking for that…all of the tasks are assigned to me (I am a solo user and not with a team). They’re just not showing up on the calendar. It’s so strange…they used to, and then one day…poof. And I can’t add new tasks using the calendar either. It seems like a bug.

Welcome, @Cristina_Bahr,

I think we need some screenshots to help you.

Or perhaps my solution here yesterday for a previous Cristina (!) will work for you:


That solution worked! I went to week view on the calendar and clicked uncompleted tasks (the tasks appeared!) and they were there when I switched back to month view. Thank you so much for your help! Truly appreciate it.

1 Like

So glad to hear that.

(But if a third Cristina reports lost tasks in My Tasks Calendar this week I’m going to start thinking something is up!)

Cristina Support Specialist


1 Like

Hello, my name is not Christina :), but I am having similar problems. I am new to Asana, so it may be something on my end. I did check the calendar view and made sure I had All task selected, but I have a couple of task that are not showing up when I go to Home/Inbox or My Task. They are not sub task and I do have a due date assigned and I am a solo user. Any advice?

Welcome, @Patrick_Brunson (not Christina!),

Let me make sure I understand. You wrote, “I have a couple of task that are not showing up when I go to Home/Inbox or My Task.” Is that the problem? If so, let’s focus on My Tasks because Home has different configurations and Inbox is more about showing notifications.

Which view (tab) in My Tasks are you not seeing the task? List view? Calendar view? Both?

Are you the Assignee of the task? If so, the task should show in My Tasks > List view or Board view. For the task to show in My Tasks > Calendar view it must also have a Due date.

For the view where you expect to see your task, change the Filter, Group by, and Sort because maybe you’re not seeing due to one of those settings.

Hope that helps,