Bug: Task lists revert to default view when switching between organization and workspace

I have both an organization and a workspace. In both versions, my preferred view for tasks is by incomplete task, sorted by project. In the new version, when I switch back and forth it defaults back to an unsorted list of incomplete projects so I have to then reset my view options, every single time. This was never an issue before. I’m curious if anyone else is having this issue and if there’s a way I can make this setting stay permanent as it’s frustrating to have to customize every time I go back and forth (which is many times a day).

Correction: defaults to an unsorted list of incomplete tasks not projects.

Welcome to the Community Forum @Elise_Weeks and thanks for reporting this issue! This is actually a bug our Development team is currently working on! I’ll be in touch as soon as I get confirmation that this is resolved!

2 Likes

Something changed on the website in the past few weeks. Whenever I change workspaces, it reverts to sorting by Priority, and if I select Sort By Due Date, the “Save View For Everyone” link disables.

Hi @Robert_Haasdyk and thanks for your report. This is actually a bug our team is currently working on; we have another thread on this specific topic, so I have moved your post to this other thread :slight_smile:

When I select a filter view, I’d like it to stay that way until I change it to another filter.

For instance, I have a project in list-view. For this particular project the most important thing is to filter by due-date. I don’t need any other view. Therefore after I’ve chosen to filter that way, I want it to stay that way – I want it to stick – until I decide to change it to another filter. Does this make sense?

Hi @Matthew_Maes, we already have a thread on this topic, so I’ve gone ahead and merged your post. This is a bug our team is currently working on, have a look above :slight_smile:

Thank you so much, that would be wonderful!

1 Like

I’m not sure what I’m doing wrong, but I have my “My Tasks” view filtered for incomplete tasks, by project. I have also selected the “save view for everyone” option. Unfortunately, whenever someone from my team uses “My Tasks”, the view is set to “none”.

My teammates are required to manually change the view each time they go to “My Tasks” as it always reverts to “none”. Personally, I don’t have this problem. My view always defaults to being sorted by Project, and the setting indicates that I have set this for everyone:
image

I have tried changing this setting multiple times to give it a kick-start, and have cleared browser caches etc but have had no luck. How can I ensure that my colleagues see their “My Tasks” by Project as the default view?

Hi @Car.Q and welcome to the Forum! I think your colleagues are impacted by a bug our Team is currently working on :point_right:https://forum.asana.com/t/bug-task-lists-revert-to-default-view-when-switching-between-organization-and-workspace/30128

I’ve gone ahead and merged your post with the main thread, and will make sure to keep you updated as soon as this is fixed. In the meantime, apologies for the inconvenience caused!

I have two workspaces and in both of them I have saved “Sort by None” as the default view for everyone.

However, when I switch between workspaces, I always get the view “Sorted by Priority” even when I never set that or wanted that.

When I click “My tasks” this sorting goes away and I can see tasks correctly sorted “By None”. There isn’t even an option to “Sort by Priority” anywhere (and I don’t want that).

Check attached screenshot, that is the situation after switching workspaces.

after_workspace_switch|320x397

after_workspace_switch

Hi @Doge and welcome to the Forum :slight_smile:

This is a bug our team is currently working on; it should hopefully be fixed soon. I’ve gone ahead and merged your post with the main thread so you can follow-up on the latest updates there!

Just to add a comment here - I’m seeing the same behaviour. Annoying but not critical - glad to know it isn’t something I’m doing wrong! Hopefully we’ll get an update on the fix soon?

Thanks for the report @Leigh, we’re experiencing some delays here, but i’m keeping a close eye on the situation, I’ll make sure to keep you to let you know as soon as we have a fix out!

Does “Save View for Everyone” not actually save view for the person setting this up? In “My Tasks” I have set: view=incomplete tasks and sort by due date, but whenever go to My Tasks it is sorted randomly and “Save View for Everyone” is grayed out (not clickable). If this view is saved for everyone, why isn’t it the view I see when I go back to My Tasks?

Hi @Melissa4 :wave:t3: “Save View for Everyone” does save the view for everyone, so if someone is visiting your My Task they should see the same view than you! With that said, we currently have a bug that could impact you. Our Team is currently working on it and is hoping to have a fix soon! Keep an eye on this thread for the latest updates!

Yes, that bug looks like what I’m experiencing. Because I am not seeing the view I saved for everyone – it defaults to some sort of random sorting.

1 Like

Thanks @Melissa4; I’ve gone ahead and merged your post with the bug thread, and I’ll make sure to post an update as soon as I have an update.

Hi,
We are having the same issue in that we select Sort: Due Date and as soon as you go out of tasks it reverts back to the default. Mighty annoying. Is this going to be fixed anytime soon as I saw people posting about this back in October?