Bug? I can not assign Task to other Projects - list of projects is empty



I have problem and since I am free user, I was recommended by support to ask here first :slight_smile:

I have problem with attaching task to other projects.

It used to work great, but now when I want to add to another project, the list of projects is empty. List of projects to add task to is only visible in “My Tasks”

I tried reloading, logging out and clearing cache. And all suggestions from: https://asana.com/guide/help/faq/connectivity#gl-troubleshooting

Thank you for your help!


Hi @Robert_Kowalski! I’m the Community Manager at Asana, it’s nice to meet you! I was just about to suggest that you use our troubleshooting steps, so I’m glad you’ve already done that!

We’ll be happy to help. I’m a bit unclear on your question. Are you saying that the list of projects no longer pre-populates when you try to add a task to a project, like so?

If yes, then this is a bug we’re aware of. In Personal Projects when you try to tether a task to another project, existing projects don’t appear in the dropdown, only the option to create a new project. We apologize for the inconvenience! Our product team is aware of the bug and they have prioritized working to solve it.


Yes, thank you Alexis! This is precisely this Bug!

If some people have this problem there is small workaround - you can still add Projects to Tasks in “My Tasks” view.

Thank you for detailed response!
Hope you fix it, Asana team does great work! :slight_smile:


Thanks for confirming, Robert! Nice of you to add the workaround.


Hi Alexis, This issue has been annoying me for weeks on a daily basis. Any update on a fix? If “Personal Projects” don’t get the attention normal workspaces get I could also live with being able to delete/disable it completely (I’ll just add a workspace) but having it ‘mandatory’ but dysfunctional is a bit of a downer…


Hey, check troubleshooting or refresh cache. On my side the problem is fixed. Adding projects works how it should.


@Joost_de_Vries please let us know if Robert’s suggestion works for you or if you’re still having issues. Thanks!


It has not. Just did a complete wipe of browsing data to no effect. What’s even weirder is that I get projects I deleted ages ago popping up in the list sometimes.


How strange. Thanks for letting us know of the issue! We’ll try to have it resolved as soon as possible.


+1 here. I emailed Asana support about this issue yesterday and got the Robot response which lead me to this community. This seems like the closest issue to the one I’m having. The issue I reported is below:

Of late this has been happening more and more often. Basically, let’s say I create a new task and try to assign a project by clicking on the Add Project button in the task details pane. When I start typing the name of the project, it doesn’t find my project. It wants me to create a new one.

Now here’s the crazier part. I can drag the task onto the project and it’ll assign the task to the project. Here’s why this seems crazy to me. I could have sworn that I read somewhere that you guys turned that feature off. And I know that it was because I was super unhappy about it, because I loved that feature.

I’ve opened Asana in a Safari and Chrome and it does the same thing in both. I’ve tried incognito and I’ve tried all the troubleshooting steps you described. I’ve tried it on a brand new OS install using a fresh untouched version of Chrome (in a VM), and same thing.



Hi Andre! This is a bug we’re aware of. Thanks for letting us know you’re experiencing this, too.


Yes This has been annoying for months. I can type the entire project title word for word it just wants me to make a new project with the same title.


+1. This has also been driving me crazy for months. Makes Asana almost useless for me. Unfortunately, I cannot assign tasks to many projects even from MyTasks section. I have tried on Safari and Chrome and wiped cashe clean on both. No dice.

For me this issue is that some projects don’t appear at all in the dropdown list, but others do. Would be great if this were prioritized.


Thanks for checking in. Hopefully this will be resolved soon!

Workspace update problem