Tasks without Assignee or Project fall into the abyss

Hello Community,

I’m finding an issue with Tasks that are created without an Assignee, or a Project, basically fall into the abyss. They don’t show up for me (even though I’m an admin to manage our projects), and I can’t find them unless I search for them but I need to know the name or keyword to find them.

This happens for me often when I create a Task from the share flow of the iOS app (it doesn’t associate the task to a project), or when I’m trying to re-assign the task and navigate away from the tasks then it just magically falls into the abyss.

Support told me to set up a private project to associate tasks to, but this doesn’t seem like a good workaround for losing data with tasks disappearing.

How have you worked around this? I’m hoping something is fixed with this soon.



If you’re using the free version of Asana, I advice you:

  • if you assign a task to a colleague, then to always associate a task to a existing project. If the task is not attached to a project, you can create a private project called for instance “Tasks I assigned to others” and thus you’ll never lose the task.
  • if the task is assigned to you, then no problem because you will have it in your “MyTasks”

If you’re Premium, then you can avoid creating the project “Tasks I assigned to others”, because you can use Advanced Search and define a report of the tasks you assigned to colleagues.

1 Like

I’d like to support @Julien_RENAUD’s idea and suggest that if you’re on premium, create a search report to find all these tasks and save it so you can always quickly access these tasks in the “abyss”.


Maybe I’m not understanding a subtlety. But have you tried this in an Advanced Search?


In addition to my previous post, you can also “Create a follow-up task”. Doing so you will have a task assigned to you with (in the description) a link to the task you have assigned to your colleague. Thus you will have a remind to “follow up” at the due date you choose.
I discovered this feature a few days ago and it is great :slight_smile:


Hi @Julien_RENAUD thanks for these tips. I am on the free plan so the premium options don’t really help me at the moment. Sometimes I will create a task from force touch or share menu on iOS that doesn’t give me options to assign to a different user or a project.

I know I can have these workarounds, but my problem is what happens after that task doesn’t have an assignee or project associated (even after I’ve tried everything to prevent it). Then at that point it is in what I’ve called the abyss.

I also manage projects for team so they’re not always in My Tasks, therefore they are so just “gone”.

hi @RyanE i’m on the free plan so this doesn’t apply to me at the moment. thanks for the tip though.

Another idea: one the free version you can not customize reports but you have one default report “Tasks I have created”. Then you can reopen the tasks from there on your computer and associate them to a project.

Hi @anthonyprice, I’m on the free plan also. You should be able to do that search if that’s what you need.

Being a new user, I immediately found this problem too. I feel like a task management software shouldn’t have the ability to allow an abyss for users, but here we are!

Essentially, it’s one of the biggest downfalls of Asana’s free version so far.

Here’s what I’ve been doing: under “My favorites,” click “Show recents and more…”
Once there, you can select all items. All items include the ones without projects or assignees.
This is the best way I’ve found so far. It’s awful having to look through every task. It seems like that’s intentional on Asana’s part.

1 Like

Hi @Jeremiah_Forrister,

I mentioned a way to find things that are unassigned:

I think people are missing the “nobody” I put in “Assigned To”, or I’m missing some finer detail. It then returns every task that doesn’t have an assignee. If you get too much back, restrict it by project or tasks you’re a collaborator of.

I am using the free version of Asana as well.

If that still isn’t working for you, let me know how. I might be able to offer more advice.

Unfortunately, our organization does not have access to Advanced Search under the free version we’re using. So, we’re still looking for a better way! Thanks for the response.

Sorry @Jeremiah_Forrister,

I wasn’t aware there was another free version out there. I can’t find anything mentioned that Advanced Search isn’t available to everyone, @Alexis?

So when you click in the search box, you don’t see the circled area at the bottom of the pane that pops up?

Here’s what we see -


Here’s what happens when you click on advanced search -

Here are the prices after clicking on “Get Advanced Search” -

Huh. I’m kind of blown away. There must be different free versions based on when you started using Asana or something… Sorry to have kept pestering you all.

This pic is showing I have the upgrade button and advanced search:

This makes helping people kind of difficult if there’s going to be different features for people using the free version.

I have also experienced this issue. I have to create a new task in a project that I name “Project Marker” and assign to myself to have a quick list in my tasks of active projects.

this is really helpful - thank you - I was also loosing tasks that had not been assigned

1 Like

Luckily I just kept going back in browser and found all tasks those were unassigned and I assigned those to a project and I was saved.