BUG? Export > Sync tasks to Google Sheets

I noticed that when exporting a project or report to Google Sheets, any dates (e.g. start date, due date, created, last modified, etc.) render as a random(?) 5-digit number rather than a date format. However, the dates render correctly when exporting to .CSV format.

Please let me know if this is an error on my side! Thanks :slight_smile:
Ashley

2 Likes

Usually, that 5-digit number is really a date, just formatted as an integer. You ought to be able to reformat it as a date within Google Sheets: Format/Number/Date.

2 Likes

Could you please tell me how you set up Google Sheets as a printer? I’d like to export a report to Google Sheets, however, I don’t have that as a “printer” option.

Like this. I have Premium, not sure if this is available in other service tiers.

I am trying the Business level…, however, I don’t see that option.

That is mysterious.

i see you show the export on Tasks you’ve created. Do you have the same options when exporting a report or project?

Yes, I do. I take it you do not?

I do not

Brenda

@Brenda, @Stephanie_Oberg,

At one point I had to request Asana Support to enable this, see:

Perhaps that’s still the case?

There’s also this (for Portfolios):

Hope that helps,

Larry

1 Like

Yes, that’s right, I had totally forgotten having had to do that.

2 Likes

Thanks! Is there any way to have it automatically export as a date so I don’t have to manually reconfigure the exported file every time?

Not that I’m aware of. You could write a macro and create a button to apply it, thus reducing the tedium slightly.