Asana links opening in browser not Desktop App (Mac)

Continuing the discussion from Task Links Opening in browser not Desktop App:

FYI for anyone having an issue with asana links not opening in the desktop app when clicked from slack or email - mine has been broken for AGES, like, almost a year.

Finally after many many attempts to change a multitude of settings in slack/asana/chrome/mac, forum deep dives and two chat help sessions, this worked: *

“Would you kindly log out of the Asana desktop application and re-login? It should forward you to log in through the browser, then Chrome should have a pop up for you to check a box to allow chrome to open links in the app. Once you have been logged in, would click on an email link to see if it will prompt you to open it within the Asana desktop ?”

** NOTE I also logged out of my browser too, to ensure it would prompt the login properly & I’m on a mac, using chrome.

This fixed my issue for links clicked from slack or email, both were opening in browser.

16 Likes

Thank you so much. So easy once you know! Loggin out and in again in the mac desktop app totally did the trick for me.

1 Like

Thank you! This worked for me.

1 Like

The feature worked for me until I had to clear my cache. Not sure why this would cause a loss of this function, but happened immediately. So I went into my Asana browser settings and the option to toggle this feature on/off is no longer available to me. So I followed the steps above even through I’ve rebooted my MB Pro several times since then, but the option is still missing. Having said that, it is on my desktop app and it’s active - even has a link to manage it’s setting in the browser. But when clicking it, the only options available are for Harvest Time Tracker and other authorized apps.

Thanks for the advice… Worked great for me

Worked for me too! Thank you! I had tried so many other things and it didnt work!

I had the same issue with my browser (I could only get to asana pages if I was already in asana - no links, no chrome searches). I had also recently cleared my cache - so I logged out and back in. Seems entirely fixed! What a strange glitch

I tried this and it didn’t work. The dialogue was prompted and I made sure to choose “always open with asana desktop app” - but opening an asana link in a google task stubbornly opens asana in chrome…

Hi @Sebastian_Kälin, welcome to the Asana Forum! I recommend you trying these quick troubleshooting steps and if the issue persists, please contact our support team: How to contact our Support Team ✉

This topic was automatically closed after 2 days. New replies are no longer allowed.