Asana links opening in Firefox, not Mac app - How to fix?

When I click an Asana link (https://app.asana.com/*), it opens in my default browser (Firefox). How do I get links to open in the native app on my Mac? I’ve checked out the Applications section of the Firefox settings, and Asana links are not listed as a filetype I can control - things like Zoom are, and Zoom has the correct handler selected.

I have tried uninstalling and reinstalling the Asana app, but nothing changed. If it matters, I was not asked to sign in again after reinstalling, so maybe I had an incomplete uninstall?

Thanks for any suggestions to get links to open in the app!

Hi @Nick-S

Could you try setting Chrome as your default browser AND then logout from the Asana Mac app

Then try logging in to Asana on the Asana Mac app…you should then be redirected to Chrome to login, after which Chrome should show you a pop up “to allow chrome to open links in the app”.

After accepting that box try accessing an Asana link and it should open in the Asana Mac app

Hope this helps!

Were you using a different default browser when you logged into the app by any chance? I was having the same issue, but logging out of the app (not uninstalling it as you mentioned) and logging in again, worked. I was redirected to Firefox to complete the login, and then needed to accept a prompt to redirect all Asana links to the Asana app. Hope it helps!

This worked! A simple log out and back in, and I was prompted by my browser to allow the links to open in the app. Thanks, @Cris1 !

@Harsh4 , thanks for the suggestion, but switching the default browser to Chrome wasn’t a good option for me.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.