Task links opening in browser, not app

I understand from the most recent update:

  • App Links: Desktop users will be prompted to open accessed links in the desktop app. You will have the ability to open in Asana once or always, or to cancel and open the link in your browser.

However, when trying to access task links from email, links are automatically opened in web browser, and not the desktop app. I never received any kind of prompt to direct links otherwise?

Please assist, thanks!

1 Like

Hi @Chantelle_Crawford, thanks for reaching out :slight_smile:

In this case, I suggest uninstalling and reinstalling the desktop app and allow the prompt to be shown again :slight_smile:

Please let me know if this works for you!

Nope, still no prompt… at which point is it supposed to load?

I’m having the same issue despite setting the browser to open the links in the app. It doesn’t seem to be working after logging in.

Same. I just uninstalled and reinstalled, and there was no prompt to open links.

I admit I didn’t know this was an option. I figured they all opened in the browser. I would prefer to have it open in the app. I will give the uninstall/reinstall a shot, but I am new to the tool and don’t recall ever being prompted to open in-app vs. browser. I wonder if it is a permissions issue on my profile. Either way, I am going to follow and watch for a solution.

I am having the same issue. All links are opening into a tab rather than the app and at installation there is no prompt for a “open in” setting. I also checked in “preferences” for the app and there is no such setting, a bit frustrating that I am still taken to the webpage when using the desktop.

Hi all :wave:t2: I’ve gone ahead and raised this with our Product team as it looks like unexpected behaviour. I hope to have an update soon!


The Mac Desktop App will only open links in Asana. I did not get the option to open the links in Chrome. In addition, the version of Chrome used by the app is out of date.

I don’t see an option in preferences to turn this on and off

1 Like

Hi @Courtney_Trusty, welcome to the Asana Community Forum :wave:t2:

Our Engineering team have confirmed that this is a bug and they are currently working on a fix. I’ll let you know as soon as this is resolved! :slight_smile:

Hi everyone, thanks for your patience here! Having looked into this with our Product team, they have confirmed that the feature for task links to open in the desktop app has not yet been fully rolled out to all users!

While you might not have access to this feature just yet, you will soon! I’ll keep you updated on this thread once this rolls out to 100% of users :slight_smile:

Hi all, just a quick update that this feature has now rolled out to 10% of users :tada: (log out and back in to see if you are part of this 10%). I’ll let you know when 100% of users have this feature :slight_smile:

1 Like

Sweet! Will try later.
In the meanwhile, I tried “Open with” which results in a line of code that I’d identify as a bug.
Seems like you’re on it, and we’ll be happy native app users soon!

It does’nt work.

I tried to uninstall, restart, reinstall the app. (MacOS 11.4). Then clicking on a the “Answer in Asana”-Button within the Asana-Email of a ticket. No prompt. Just opening it in Browser.

This topic was automatically closed 16 days after the last reply. New replies are no longer allowed.