Are the Rules applicable only to the Board View?

I tried adding a rule in list view but it did not work but when I use the board view, the rule works. Is there a way that the rules would also work in the list view? 2021-08-17_01-21-51.png - Google Drive

The Rule is Set due date
Trigger: Task is no longer blocked
Action: Set due date (1 day)

Hey @Rica_Tolentino, welcome to the forum :wave:

Normall the rules should work on the list view also. The rules will run midnight every day so maybe this was the reason?
Not sure what time you tested this, maybe it was just before midnight when you tested on list view and then bit later board view when the trigger for midnight kicked in?

Here is more info:

Actually that rule trigger runs immediately; it’s only the date-based rule triggers that only run at midnight.

Asana rules don’t care what view you’re in, so there’s something else going on besides the view that’s causing you to see the rule work in some cases and not others.

Did you try it on two different tasks, one in list and one in board, or was it the same task in both?


Hi @Phil_Seeman it’s the same task. When I switch it to listview, the rule didn’t work. But when it’s in board view, the rule runs smoothly.

I am using rules for “My Tasks” and for some reasons it took 3 days before rules started working as I expected.
I love this feature it is moving my tasks to :

  • upcoming taks
  • overdue tasks
  • tasks to assign a due date

Something which is a bit confusing is that some rules indicate that they did not run for 3 days, others for 18 days. I assume that it is because the rule did not find any tasks to move.

Hey @Ronny_Lion,
if your rules did not run yes maybe there were no tasks or changes that would trigger a rule to run.

In case there should be and there seems to be any issue I recommend to contact support so they can look into this directly for you.

Hey @Rica_Tolentino
huch that is weird then.

I recommend contacting Support to look into this in detail.
Ideally attach a short video also showing your set up.

1 Like

Looks like it’s ok now. It’s just weird that it wasn’t working when I first time I tried it. Thanks!